This question is similar to How do you rename a printer device in Windows 7 64 bit, except the answers there do not work, and I'll provide more information.

This is a home network, not a domain. I have set up a Brother HL-5170DN. It is a network printer connected directly to an Ethernet hub. I can connect to it with Windows 7, but on Windows 7 it defaults to the name "binary_p1 on Brn37415f", which isn't very useful. And I cannot seem to change the name.

I have it working with several Windows XP and Vista machines, and I can change the name on those machines.

On Windows 7 Printer properties:

  • I can see the "binary_p1" name on the General tab. I can select the text, but I cannot change it. The field is not grayed out, but I cannot type anything into it.
  • On the Ports tab, all of the controls are grayed out (disabled). The selected Port is called "\\Brn_37415f\binary_p1", and it's described as "Client Side Rendering Provider" and the printer field says "binary_p1".
  • On the Security tab, I can see that my account has "Manage this printer" permissions.

If I choose Printer Server Properties, I can select the port and click Configure Port, but I get a dialog that says, "An error occurred during port configuration. This option is not supported."

I have found many forums with people asking the same question without getting an answer.

Update: No more bounties to offer, but I'm still looking for a solution to this problem.

  • How did you add this printer? did you add it as network or local? If network try adding it as a local printer and when you get to ports create a new port, select tcp/ip, and put in the IP of the printer... You can then name it whatever you want... – Supercereal Jul 6 '11 at 18:03
  • What is the device make/model the printer is shared from? – edusysadmin Jul 6 '11 at 18:20
  • @Kyle: I added the printer as a network printer. The printer relies on DHCP, so the IP address changes from time to time. I haven't found a way to give it a fixed IP address with my Netgear router. I used to be able to do that with my old Linksys. – Adrian McCarthy Jul 7 '11 at 12:43
  • @edusysadmin: I'm not sure I understand your question. The printer (Brother HL-5170DN) has a built-in print server. I just connect the Ethernet port to my router. – Adrian McCarthy Jul 7 '11 at 12:44
  • Possibly related: randomascii.wordpress.com/2015/01/05/… – Adrian McCarthy Jan 6 '15 at 17:43

Here's the way to do this on Windows 7 and 8.1 for non-IP based printers:

  1. Add a printer
  2. Add a local printer (not network)
  3. Create a new port (local port, not TCP/IP)
  4. Fill in portname (\server\printer syntax)

Follow the rest of the steps (you likely will have to manually pick the printer driver, you can find this easily if you already mapped the network printer by viewing its properties).

This will let you do this.

  • 1
    Confirmed works for windows 8.1. This should be the accepted answer! – Zoomzoom Sep 14 '17 at 21:36
  • I'm unclear on step 4. What am I supposed to put for the server name? – Adrian McCarthy Oct 16 '17 at 20:47
  • @AdrianMcCarthy in your post it looks like \Brn_37415f\binary_p1 though this is old enough I do not actually remember off hand. Presumably adding it as a regular network printer will let you see this however as you can inspect the printer to see what its server address is. – enderland Oct 16 '17 at 21:20
  • I think \server\printer should be \\server\printer. – BornToCode Mar 1 '19 at 1:39

This worked for me:

  1. Stop the print service
    net stop spooler

  2. locate the printer in the registry under
    Network printers usually have a key which starts with to commas, like

  3. Be $new the desired name of the printer. Change:
    value of "Name" in $device to $new
    value of "printerName" in $device\DsSpooler to $new
    value of "uNCName" in $device\DsSpooler to \\$computername\\\$new
    finally rename the printers registry key from $device to $new

  4. restart printer service:
    net start spooler

Info gathered from
http://sevenforums.com/hardware-devices/89521-rename-network-printer.htm http://virtualroadside.com/blog/index.php/2007/10/17/prnrename-an-autoit-based-utility-to-rename-ipp-printers-in-windows/

  • This one looked the most promising, however when I attempted to try it, the registry key 'Print' was not in 'CurrentVersion', also tried the WOW6432Node branch. – Lockszmith Oct 8 '14 at 13:53
  • This one worked for me in windows 10 as well. – Paul de Vrieze Aug 5 '16 at 16:07
  • The default name of my IPP printer was "gateway-usb-printer" on Windows 7, I couldn't change it using the windows UI. The solution based on "PRNCNFG.vbs" didn't work either, it failed with the error 0x80041002 (not found). The modification of the registry as described in this answer is the only thing that worked. – ocroquette Aug 21 '16 at 15:28
  • This solution worked for me, when the simple methods like editing the name directly under Printer Properties did not work. – Therkel Sep 22 '16 at 7:27

I just did it on my Windows 7 installation.

Go to Device and Printers, right click on the printer you want to change, select "Printer Properties", not properties or printing preferences. Change the name in the top box. Hit OK when done.

Enter image description here

Enter image description here

  • 14
    In my case, the text in the top box is not editable. I can select it, but I cannot change it. You example is not a network printer. I think that's a key difference. – Adrian McCarthy Jul 6 '11 at 17:44
  • Try a switch instead of a hub, might make a difference. – Moab Jul 6 '11 at 21:39
  • 1
    I misspoke. It is a switch, not a hub. – Adrian McCarthy Jul 7 '11 at 12:40
  • 2
    Thanks. This worked for me. Both the right-click > Rename and File > Rename were disabled, but the text box in the Properties window was editable. Also, my printer is a network printer, not local. – mikesigs Mar 28 '13 at 14:49

You cannot rename a network printer in Windows XP, Vista or 7 (not sure about others). The only way to rename is to rename it on the server, but this will break existing configuration.

There is a workaround though: you can map a LPT port to a network printer and then install as a local printer.

To map a LPT port use the following command on an command prompt with administrator privileges:

net use lptX \\Brn_37415f\binary_p1 /persistent:yes

Replace the "X" with the LPT port you want to use, for example 2 (if your mainboard has no LPT port you can use 1 too).

Then just install the printer as if it was a local printer attached to the LPT port you specified

  • 1
    Actually, I can rename the printer on XP and Vista. Just not Windows 7. There is no distinct print server per se. The server is built directly into the printer. – Adrian McCarthy Jul 7 '11 at 12:31
  • The net use command worked, and I was able to install the printer as a local printer on LPT1. Unfortunately, printing to it gets a generic "Error - Printing" status in the queue and nothing prints. – Adrian McCarthy Jul 7 '11 at 12:36
  • Did you use the correct drivers? Sometimes there are different network and local drivers. Also, can you print from the command line to the port? (google it) Also if your printer is a direct network printer @Kyle's solution might work – dtech Jul 7 '11 at 15:44
  • I believe I'm using the right drivers. I tried the ones from the manufacturer's disk and then I uninstalled those and tried the ones from Microsoft update (exact match on model number). Trying to print from the command line get the same "Error - Printing" status in the queue. – Adrian McCarthy Jul 12 '11 at 14:58
  • Awarding bounty to the highest voted response because it's out of time. Unfortunately, I still don't have an answer. – Adrian McCarthy Jul 13 '11 at 13:13

I am experiencing the VERY same issue, but I might also add to what's already been discussed...

If I connect to a shared printer on my domain (the PC is attached to a workstation, NOT the server) I do NOT get the printer installed on my workstation as the shared name...

The share is called HCFA, and appears as such in the network browser.

When I double click it, the driver will download and install, but the printer is named on MY computer as "HP LaserJet 1320 on XXXX", and I cannot rename it locally, or it breaks the share to all the OTHER computers that are connected to this same printer, EVEN IF I rename it locally to the very same name as the remote share already has.

The workstation is a DHCP client, but it has a reservation in the scope for itself. I had to do this when one of the XP workstaions in my organization stomped on it's IP, and DNS lost that workstation. I can now browse TO the workstation, and see and connect to its shares, but I cannot rename them.

I suppose I COULD just add a 170x to the network... I'd really like to know why I can't use this the SAME way I would have setup an XP shared printer. < mumble > I hate Windows 7... < /mumble >

  • 2
    I'd be thrilled if it would show the model as the name of the printer. Mine it much more cryptic. – Adrian McCarthy Jul 13 '11 at 13:12

After testing both, I found this to be correct:

You need to add the printer as a local printer in order to change the name, otherwise Windows defaults it to the share name.

When you add the printer select local. Then select create port and specify TCP/IP:

Enter image description here

Then put in your printer's IP address:

Enter image description here

Then just follow the wizard as you would with any other local printer installation.

  • This will only work on a pure network printer though, not on a printer shared through a windows PC. – dtech Jul 7 '11 at 0:58
  • @dtech "I have set up a Brother HL-5170DN. It is a network printer connected directly to an Ethernet hub." sounds like a network printer to me... – Supercereal Jul 7 '11 at 2:17
  • The problem with this solution is that the printer gets its IP address from DHCP, so it changes from time to time. I've tried setting the router to always serve it the same IP address, but that's not possible with my Netgear access point (it was with my old Linksys). – Adrian McCarthy Jul 7 '11 at 12:40
  • @adrian you can do it with any router..... just lower the dhcp pool: say it gives just lower it to and manually set the IP on the device. honestly you don't even need to involve the router if you are not worried about having 250+ devices on your network. – Supercereal Jul 7 '11 at 12:46
  • @kyle: As far as I can tell, there is no way to manually set the IP address for the printer. It appears to be hardcoded to rely on DHCP. – Adrian McCarthy Jul 12 '11 at 14:57

If you like, rename the printer on the network:

  1. Right-clicking printer properties, then clear text and type like name
  2. For computer network, RUN > \\computer_name to connect to the printer and double click.
  • 2
    As I said in the question, the name in on the printer properties page is not editable. – Adrian McCarthy Feb 24 '16 at 18:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.