I have 2 * Maxtor Onetouch 4 Lite 500GB external hard drives (part no. 9NT2A4-500). They both used to work fine on my old laptop (an Acer) but I have not used them for about a year, since my laptop was stolen and I got this one (also an Acer [Aspire 7738G]). I have one plugged into the mains with one of the leads I believe was supplied with them. It appears to be receiving power as it is warm and the power light (on the unit itself) is on; also the mains adapter is fairly warm.

I also have it plugged into my laptop with a USB lead which I have tested on my mp3 player (so I know it works). However my hard drive is not showing on my computer. I have tried checking for new hardware, installing the software that was supplied with it, checking drive letters in case it is registered as C: or something stupid, checking for problems etc... I can't find any cause for it to do this. It does appear to be starting up and, possibly, shutting down and restarting constantly (that's what it sounds like altho I can't be certain).

I have had both hard drives stored in different places for the last year and they're both doing the same thing.. if it was only one then I'd guess it had got damaged or corrupted or something but since it is both I doubt this is it. The only things in common with both of them are the leads and the laptop, however I know the USB lead works and guess the mains lead works as there is power going to the unit.

Has anyone come across this before or does anyone have any idea what the cause / solution to the problem is? Any help would be greatly appreciated.

Regards, Richard


I'm not sure what operating system you are using so I'll provide an answer for all versions of Windows after Windows 2000.

A tool called USBDeviceView will be a good first port of call, this will show you what USB devices are actually appearing to the operating system: http://www.nirsoft.net/utils/usb_devices_view.html

If the drive(s) are being picked up, it may be that they are not partitioned or formatted yet. Right click (My) Computer on the Desktop or Start Menu (whichever it appears in), then click Manage.

Select Disk Management, and if the drive appears, right click the blank area and format the drive as you wish (the default settings are usually fine).

If drive(s) are still not being detected, try them in other USB ports. I have found in some cases certain devices only work in certain ports. Also, check if the drives work in another PC if you have access to one.

  • I'm on Windows 7. I just tried out this USBDeviceView program and found them listed - but "connected" displayed "no" for both of them. They've been used a lot before and were formatted before I used them. I've tried all USB ports and still no luck. I have installed the software from a website; not from the disc supplied with either of them as I don't have access to the original discs right now, nor do I have access to another computer at the moment. The fact that both drives were listed in DView suggests to me that they've been working on this computer in the past. – ClarkeyBoy Jul 3 '11 at 21:48
  • Using USBDeviceView, try uninstalling the device then re-attaching it, letting Windows re-detect the device. This may work... it is quite hard to diagnose without having another system to check the drives on however. – Ruairi Fullam Jul 3 '11 at 21:56
  • I just tried that - it won't reinstall them as it still isn't detecting them. Dunno whats going on but I've seen on another post that it may be fried... it's always possible, I suppose.. :( – ClarkeyBoy Jul 3 '11 at 22:20
  • Sorry to hear that. By all means ask again if you manage to get the drive working on another system and I'll do what I can to help. – Ruairi Fullam Jul 3 '11 at 22:28

I lost the partition on my 500 mb Maxtor - a data recovery utility called testdisk recovered the bad partition. There's a howto on how to use it on their site

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.