I tried to encrypt a very large file 100+ gig using EFS and canceled when it said it was going to take 12 hours. Cancellation hung until I finally rebooted the system and now I'm unable to delete the file or open it because windows (7) still believes it's open in the EFS system.

I've tried process monitor, but searching for the file there doesn't turn up any processes I can kill to delete it.

Any suggestions on how I can take ownership of this file to delete it?


You can also use a utility called Unlocker to release the file handles:


  • 1
    I hate to have to resort to third party programs just to delete, but unlocker did the trick. I first unlocked and deleted a related temp file that was in the same directory ( EFS0.TMP ) and then tried to delete the file itself, the first try failed but the follow-up option to delete on reboot worked.
    – Aaron
    Jul 4 '11 at 1:27

Its not the easiest way, but in safe mode it should be possible, and for sure in another OS...

  • I should have mentioned that I tried safe mode, unfortunately the files would not release there either. Maybe because EFS gets started as part of safe mode?
    – Aaron
    Jul 4 '11 at 1:14
  • Sounds like its running as a core system utility, which means the odds of unlocker working are close to zero also. Can you boot to a live CD of some kind? cause that will for sure do it.
    – soandos
    Jul 4 '11 at 1:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.