After connecting from my home via remote desktop, both my screens are black when I arrive at work. The only thing I can see is a mouse pointer on one of the screens. I then seem to have only two choices: rebooting or working from a remote desktop connection, which works fine.

It did happen every time I tried last week.

However, I did the same from my laptop in a meeting room today, and I didn't have any problem.


I have had a similar issue. While not a fix this is the work around we found to avoid restarting: While one of you screens is black and not showing the mouse the log-in screen is actually there.

Use the keyboard to log into your account (we press Esc a few times, then ctrl+alt+delete, then enter password and hit enter) you will log in and the monitor that wasn't showing the mouse cursor will come back to life.

Again, just a work around I'm afraid but it saves a reboot or two.

|improve this answer|||||
  • 2
    We've experienced the same thing. A user with RDP into their office desktop, main monitor is blank and second is awake (shows black with cursor) and hitting Ctrl+Alt+Del and entering in the password (if account is locked) will wake the machine. – edusysadmin Jul 11 '11 at 2:29
  • After a little reading it looks like setting the display to not sleep after x minutes in the power settings (which our PCs are forced to by policy) can solve the problem. Will make myself exempt from that tonight and see what happens. – Windos Jul 11 '11 at 2:39
  • 2
    Login screen isn't here, or not visible. ESC / Ctrl+Alt+Del / ... do nothing. – ymajoros Jul 11 '11 at 9:25
  • The screen is there, the display is not awake to show it. If you were to go through the motions to login as if the screen were displaying in front of you it'd work. – edusysadmin Jul 12 '11 at 0:43

There are a few issues and workarounds for this, so I will cover the most common cause of the problem (especially when connecting to Amazon Cloud servers):

  • for me it seems that disabling bitmap caching (1) solves the problem,
  • alternatively, as a manual work-around: forcing a full-screen redraw seems to help, to that end CTRL-ALT-END and then clicking Cancel, causes enough of a change in the cached bitmap to redraw in windows RDP.

Hope this helps, but let me know if you need any further info! :)

(1) Windows RDP Client Bitmap Caching Option

Untick the Persistent Bitmap Caching box to disable bitmap caching.

Where to set bitmap caching in windows 7 RDP

|improve this answer|||||
  • 1
    CTRL-ALT-END did help to solve the issue. Thanks – Jåcob Dec 3 '15 at 14:37
  • Disabling Persistent bitmap caching did not work in my case. Ctrl-Alt-End worked when I was only one hop away. RDP into a machine then RDP into another from it and I haven't found a solution yet. – Shiv Jul 13 '16 at 1:54
  • I shall take a look tonight to see what solutions I can come up with. Can you post whether its rdp native or rdp via citrix? – GMasucci Jul 13 '16 at 8:33
  • I've had Ctrl+Alt+End work intermittently. Disabling "Persistent Bitmap Caching" worked for me this time. I've also had luck by starting a run box, then type shutdown -l. Even though you can't see what's going on, it should log the machine off if there aren't any processes keeping the logoff procedure from happening. Obviously you'll lose work if there was unsaved stuff open. – user38537 Jul 16 '16 at 1:19

I could eventually fix it by pressing WINDOWS-P and ENTER, to choose the active screen. The screen just appears after that.

|improve this answer|||||

This fixes it:

Start Menu Edit Group Policy (not sure where it is at in the start menu, or if it is in the start menu, but the type to find worked) Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits Set time limit for disconnected sessions (set this to Enabled and make sure the option is set to Never end a disconnected session)

|improve this answer|||||

I just discovered that I could get around this issue by clicking on the login button (arrow icon) with the mouse rather than pressing the enter key after typing username and password. Hope this discovery helps others....

|improve this answer|||||

You can try two options

  1. Press Alt+Ctrl+End and after that Cancel. Your screen will come.
  2. As @user256837 described, after entering your credentials don't press Enter, just press the arrow key, I don't know what the logic behind second method but it works for me.
|improve this answer|||||

Keep windows logo key pressed and hit p until the login screen shows up. It looks like in our case this was related to desktop extension and multiple monitors.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.