When Spotify is running, it shows a little icon in the activity field. On most operative systems, closing the Spotify window minimizes the player to the activity window, freeing up space in the task bar - but not in Windows 7, it seems.

I think it's a little uneccessary to have two icons in almost the same place that does almost the same thing. Is there anyway to hide a program icon from the task bar, in this case specifically Spotify?


You can right click the tray icon and 'check' "Hide from Taskbar when Closed".

And then click the cross :)

I had the same problem and found the solution on Google.

Altough it would be great if it was also on the Preferences page where I looked first.

| improve this answer | |
  • +1 for providing the source and +100 for hinting the devs to where this should have been located – Bruiser Mar 22 '12 at 16:59
  • It should also be by default, with the classical notification that programs with that same desired behaviour show if you will. – Carles Alcolea Nov 11 '14 at 19:48
  • Not working on Windows 8. Just doesn't show that option any more... I'm beginning to hate Spotify... – user237209 Apr 30 '15 at 15:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.