I have 3 computers hooked up to a 4-port KVM switch and I am having a problem with the resolution on one of my computers. Whenever I switch to another computer and come back, the resolution goes from 1440 x 900 (where I set it) to 1024 x 768. The other two computers stay at whatever resolution I set them to, but the one computer just keeps going back to 1024 x 768. I have had the KVM switch for almost two months now and I have not had this problem before. The computer that is having the problem is a new build, but I have had it for about a week and it only starting exhibiting this problem today. I frequently switch back and forth between computers, and 1024 x 768 looks terrible. Does anyone know how I could fix this?

Additional details:

  • Computer 1: Windows 7 x64, Intel Core i5-2500k, Resolution 1440 x 900 (This is the problem computer)
  • Computer 2: Windows 7 x86, Intel Celeron 430, Resolution 1280 x 1024
  • Computer 3: Windows 7 x86, Intel Core 2 Duo E4300, Resolution 1440 x 900

Computer 1 uses the on-die graphics from the 2500-k and computers 2 and 3 use the integrated video from the motherboard.

On a different forum someone told me I needed to disable the autodetect function and sent me a link to a question (on this forum). I tried all the potential fixes (could only do one because the rest didn't apply or were not possible in windows 7) but nothing worked. The one I tried was to disable TTM in the registry by changing the value data of "UselViewHelper" under the "Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\TMM" key to "1", but it didn't work. Is there a way to disable the autodetect in Windows 7?

There is no ways to disable auto detect of devices connected of Windows 7 or Windows 8. It's your KVM switch does not pass/feed the connected monitor's correct EDID information to connected system.

You can either put an EDID emulator between your old KVM switch and each connected systems (PCs) or change KVM switch which support Full-time DDC/EDID communication.

Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.