I have a folder that contains JPEG files that I cannot open. Here is one example mystery file. Can anyone help me to open the file or suggest a way of recovering the data if it is corrupted?

[update] I found the files on an old external hard drive. The linux file command failed to identify the file type (output was like this: mysteryfile.jpg: data). Viewing the files in a text editor, I don't see any obvious file headers or anything in common within several files.

[update] I have tried and failed to open the files with Windows Photo Viewer, GIMP, Infraview, Paint and Picasa on Windows 7. Also, the default viewer on Ubuntu 11.04.

  • If @MaxMackie's solution doesn't work for you, maybe you can tell us which operating system you have and which programs you try to open the file with. – slhck Jul 6 '11 at 14:26
  • Try opening it with Irfanview. It will sometimes find the correct format if it is still an image file. – music2myear Jul 6 '11 at 14:46
  • Irfanview cannot open the files. – Liam Jul 6 '11 at 14:50
  • 1
    If you have Ubuntu, from a Terminal, run file mysteryfile.jpeg and tell us the output. – slhck Jul 6 '11 at 14:54
  • the output you posted means that the file program can't recognize the format or that it is just ... data. – n0pe Jul 6 '11 at 15:21

It's probably NOT a JPEG image. Chances are somebody changed the extension of the file, so your OS thinks it's an image. I would check the headers of the file in a text editor, that might give you an idea of the true extension. Once you know it, rename the file correctly and view your mysterious content.... (dum dum dum)


Looking at the file size of your sample image (1.44MB) it seems very likely that these are floppy disk sized chunks of a compressed file.

See if you can open one with winrar or 7zip. You may need to rename them.

  • Good spot. Will be interested to find out if that's true. – Jasarien Jul 6 '11 at 15:16
  • The files all have different sizes and some of them are over 1.44MB, so I don't think this can be correct. I tried renaming some and using 7zip but it doesn't recognise them. – Liam Jul 6 '11 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.