I have this motherboard in my machine.

I have installed an NVIDIA GeForce 8400 GS in the PCI-e x16 slot.

I have two monitors connected to the GeForce, and they work perfectly. I have connected a third monitor to the onboard display adapter, but the third monitor doesn't function at all. Windows Device Manager doesn't detect the onboard display adapter, pointing to the motherboard/BIOS disabling the onboard display adapter while an additional display adapter is installed in the PCI-e slot.

Is it possible to get around this issue, by customizing the BIOS configuration or installing a third-party BIOS image?


Generally speaking once a PCI-E adapter is detected, the on-board graphics are disabled. As this motherboard is generally integrated into HP systems, I can't see the BIOS offering this functionality as HP tend to pare down the available options to the bare essentials.

| improve this answer | |
  • This has also been my experience. I think there's no strict architectural requirement for this, though they may build motherboards this way, you could find a board that'll let you use both. BIOS settings would be where you'd have to search for an option to that end. – James T Snell Jul 7 '11 at 19:49

On a GA-890GPA-UD3H I had to change the initial graphics card to on-board, in the BIOS.

Then Windows would use all three monitors.

| improve this answer | |

I had an issue the same i went into the bios and turned the onboard on, it worked fine just connected the 3rd monitor.

If you don't have the option in your bios i really don't think you can do it.

Your options are buy an amd card that has either duel dvi or one with a display port you can't do 3 monitors with 1 nvida card or buy a motherboard that lets u use the onboard and pci ones with intel hd graphics let you do this.

what ever is cheapest if your short on cash if not just get a 6970 i have one and its awesome u can run 5 screens with simply plug and play.

| improve this answer | |
  • What motherboard did you have? This is probably relevant. – ijw Sep 1 '12 at 13:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.