Every time I open any printer queue I get a kernel panic and have to reboot. It's quite frustrating. I've tried removing/adding printers, clearing all caches with Onyx, repairing permissions, all manner of things to no avail.

Any tips would be greatly appreciated!

==== CRASH REPORT ====

Interval Since Last Panic Report: 25551 sec
Panics Since Last Report: 1
Anonymous UUID: 322E8128-0027-4C2F-9264-6A9D9F1BD13E

Thu Aug 27 10:04:23 2009
panic(cpu 0 caller 0x001AB0FE): Kernel trap at 0x00233080, type 14=page fault, registers:
CR0: 0x8001003b, CR2: 0x00000008, CR3: 0x01157000, CR4: 0x00000660
EAX: 0x00000000, EBX: 0x03f05df0, ECX: 0x2ad007fd, EDX: 0x2ad02d2d
CR2: 0x00000008, EBP: 0x2e6abb78, ESI: 0x03f136a0, EDI: 0x03f13640
EFL: 0x00010206, EIP: 0x00233080, CS: 0x00000008, DS: 0x01a70010
Error code: 0x00000000

Backtrace (CPU 0), Frame : Return Address (4 potential args on stack)
0x2e6ab998 : 0x12b4c6 (0x45f91c 0x2e6ab9cc 0x13355c 0x0)
0x2e6ab9e8 : 0x1ab0fe (0x469a98 0x233080 0xe 0x469248)
0x2e6abac8 : 0x1a1713 (0x2e6abae0 0x206 0x2e6abb78 0x233080)
0x2e6abad8 : 0x233080 (0xe 0x3e10048 0x4570010 0x96d0010)
0x2e6abb78 : 0x27866c (0x3f05df0 0x0 0x4ec4 0x3f136a0)
0x2e6abbc8 : 0x249d53 (0x3f13640 0x3e17464 0x55c160 0x3034ed5c)
0x2e6abdc8 : 0x24bb59 (0x3034ed00 0x28 0x9 0x0)
0x2e6abde8 : 0x270186 (0x2e6abe70 0x2e6abe44 0x8 0x0)
0x2e6abe68 : 0x22ca5f (0x3034ed00 0x3034ed00 0x2e6abea8 0xffffffff)
0x2e6abea8 : 0x21b36e (0x1e 0x3034ed00 0x246 0x0)
0x2e6abec8 : 0x217591 (0x3f65c04 0x1e 0x3034ed00 0x3ef2c2)
0x2e6abef8 : 0x217cea (0x530d64 0x4037808 0x3034ed40 0x2e6abf4c)
0x2e6abf68 : 0x217f1b (0x3f65c04 0x3034ed00 0x0 0x530de8)
0x2e6abfc8 : 0x1a14fc (0x530dc0 0x0 0x1a40b5 0x3dd95d0)
Backtrace terminated-invalid frame pointer 0

BSD process name corresponding to current thread: kernel_task

Mac OS version:

Kernel version:
Darwin Kernel Version 9.8.0: Wed Jul 15 16:55:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_I386
System model name: MacBook4,1 (Mac-F22788A9)

System uptime in nanoseconds: 30555146093771
unloaded kexts:
com.apple.iokit.IOUSBMassStorageClass 2.0.8 - last unloaded 26709525128459
loaded kexts:
com.vmware.kext.vmnet 2.0.5
com.vmware.kext.vmioplug 2.0.5
com.vmware.kext.vmci 2.0.5
com.vmware.kext.vmx86 2.0.5
com.apple.driver.iTunesPhoneDriver 1.0 - last loaded 981750246502
com.apple.iokit.IOUSBMassStorageClass 2.0.8
com.apple.filesystems.msdosfs 1.5.5
com.apple.iokit.IOBluetoothSerialManager 2.1.8f2
com.apple.filesystems.autofs 2.0.2
com.apple.driver.AppleHWSensor 1.9d0
com.apple.driver.AppleHDA 1.7.1a2
com.apple.driver.AppleUpstreamUserClient 2.7.5
com.apple.Dont_Steal_Mac_OS_X 6.0.3
com.apple.iokit.CHUDUtils 201
com.apple.iokit.CHUDProf 211
com.apple.driver.AppleIntelGMAX3100 5.4.8
com.apple.driver.AppleIntelGMAX3100FB 5.4.8
com.apple.driver.AppleHDAController 1.7.1a2
com.apple.iokit.IOFireWireIP 1.7.7
com.apple.driver.AppleIRController 113
com.apple.driver.AudioIPCDriver 1.0.6
com.apple.driver.ACPI_SMC_PlatformPlugin 3.4.0a17
com.apple.driver.AppleLPC 1.3.1
com.apple.driver.AppleBacklight 1.6.0
com.apple.driver.SMCMotionSensor 2.1.1d2
com.apple.driver.AppleUSBTrackpad 1.7.4f1
com.apple.driver.AppleUSBTCKeyEventDriver 1.7.4f1
com.apple.driver.AppleUSBTCKeyboard 1.7.4f1
com.apple.driver.CSRUSBBluetoothHCIController 2.1.8f2
com.apple.driver.AppleUSBMergeNub 3.4.6
com.apple.iokit.IOSCSIMultimediaCommandsDevice 2.1.1
com.apple.iokit.SCSITaskUserClient 2.1.1
com.apple.driver.XsanFilter 2.7.91
com.apple.iokit.IOATAPIProtocolTransport 1.5.3
com.apple.iokit.IOAHCIBlockStorage 1.2.2
com.apple.driver.AppleUSBHub 3.4.9
com.apple.iokit.IOUSBUserClient 3.4.9
com.apple.driver.AppleAHCIPort 1.7.0
com.apple.driver.AppleIntelPIIXATA 2.0.1
com.apple.driver.AppleFWOHCI 3.9.7
com.apple.driver.AppleUSBEHCI 3.4.6
com.apple.driver.AppleEFINVRAM 1.2.0
com.apple.iokit.AppleYukon2 3.1.13b2
com.apple.driver.AirPortBrcm43xx 366.91.21
com.apple.driver.AppleUSBUHCI 3.3.5
com.apple.driver.AppleSmartBatteryManager 158.10.5
com.apple.driver.AppleRTC 1.2.3
com.apple.driver.AppleHPET 1.4
com.apple.driver.AppleACPIPCI 1.2.5
com.apple.driver.AppleACPIButtons 1.2.5
com.apple.driver.AppleSMBIOS 1.4
com.apple.driver.AppleACPIEC 1.2.5
com.apple.driver.AppleAPIC 1.4
com.apple.security.seatbelt 107.12
com.apple.nke.applicationfirewall 1.6.77
com.apple.security.TMSafetyNet 3
com.apple.driver.AppleIntelCPUPowerManagement 76.2.0
com.apple.driver.DiskImages 199
com.apple.BootCache 30.4
com.apple.iokit.IOSerialFamily 9.4
com.apple.driver.DspFuncLib 1.7.1a2
com.apple.iokit.CHUDKernLib 201
com.apple.iokit.IOHDAFamily 1.7.1a2
com.apple.iokit.IOAudioFamily 1.6.9fc5
com.apple.kext.OSvKernDSPLib 1.1
com.apple.driver.IOPlatformPluginFamily 3.4.0a17
com.apple.iokit.IONDRVSupport 1.7.3
com.apple.iokit.IOGraphicsFamily 1.7.3
com.apple.driver.AppleSMC 2.3.1d1
com.apple.iokit.IOUSBHIDDriver 3.4.6
com.apple.driver.AppleUSBBluetoothHCIController 2.1.8f2
com.apple.iokit.IOBluetoothFamily 2.1.8f2
com.apple.driver.AppleUSBComposite 3.2.0
com.apple.iokit.IOSCSIBlockCommandsDevice 2.1.1
com.apple.iokit.IOBDStorageFamily 1.5
com.apple.iokit.IODVDStorageFamily 1.5
com.apple.iokit.IOCDStorageFamily 1.5
com.apple.iokit.IOSCSIArchitectureModelFamily 2.1.1
com.apple.iokit.IOAHCIFamily 1.5.0
com.apple.iokit.IOATAFamily 2.0.1
com.apple.iokit.IOFireWireFamily 3.4.9
com.apple.iokit.IO80211Family 216.1
com.apple.iokit.IONetworkingFamily 1.6.1
com.apple.iokit.IOUSBFamily 3.4.9
com.apple.driver.AppleEFIRuntime 1.2.0
com.apple.iokit.IOSMBusFamily 1.1
com.apple.iokit.IOStorageFamily 1.5.6
com.apple.iokit.IOHIDFamily 1.5.5
com.apple.driver.AppleACPIPlatform 1.2.5
com.apple.iokit.IOACPIFamily 1.2.0
com.apple.iokit.IOPCIFamily 2.6

Macbook Black Mac OS X (10.5.8)

  • When you say "any printer queue" are all of these printers from the same manufacturer? – Hasaan Chop Nov 19 '09 at 20:44

Have you tried resetting the printing system?

Go to Print & Fax preferences and option+click the minus button. Click OK in the dialog that appears, and then try re-adding your printers.

| improve this answer | |
  • 1
    Hey, a ProTip! Thanks for that. I didn't know about that function at all! Why does Apple do that? Some subtle dark-gray text at the bottom of the window letting me know that was an option would have been cool. Unfortunately that didn't fix it. I reset the printing system, re-added a printer, clicked the Open Printer Queue button and immediately got the darkened kernel panic screen. Thanks, though! – Gray Aug 27 '09 at 18:32

Probably not a lot of help, but here is what I've got:

  1. Have you had any failed or interrupted updates? If so, a OS re-install might be in order.
  2. I notice that you have some vmware modlues loaded. Have you checked vmware related web sites for other people having this problem?
| improve this answer | |
  • No interrupted updates. I did try to find someone else in the VMware community with a similar problem, but I didn't have any luck there. – Gray Aug 27 '09 at 17:31

Do not open a printer queue; Open the printers preference pane in the system preferences and remove all of your printers. Log out, log in, and add the printers you want, be sure to to use only new drivers. I had an issue like this with my HP 2600n after upgrading from Leopard to Snow Leopard. I needed to remove the printer, download the new driver from HP (which doesn't support half of what the old driver did) and reinstall the printer.

| improve this answer | |

Rerun the latest 10.5 Combo updater, available from Apple... http://www.apple.com/downloads/macosx/apple/macosx_updates/macosx1058comboupdate.html

Install it, Open Utilities --> Disk Utility --> Highlight your hard drive, and run Repair Permissions.

Run Software Update, and make sure everything is up to date.

Then Try again. If that didn't resolve it, then there maybe a disk issue.... Running Disk Warrior would be the next step I would suggest....

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.