I have used Final Uninstaller (unregistered version) to remove it. So it removed the toolbar and the things in its folder from C:Program Files/Ask.com except for one thing; remaining are "Ask.com" folder > "Updater" folder > "Updater.exe"

I have not checked my registry yet. But if there is something I want it to be gone!

As to why I can't delete that updater thing, my laptop asks me permission (says need to be admin) whenever I tried to delete anything from ask.com folder, or its folder at all.

I have googled, came to and followed the instructions from "Scott McClenning" in this post. Does not really work. When I say "not really", means, this error message pops up everytime I tried to do that:

An error occurred applying attributes to the file:
C:/Program Files/Ask.com
Access is denied.

How can I gain access? I AM the admin for this computer.

And... don't ask me to download too many things for my computer, it adds to my frustration.

Just in case you are wondering, I got this from FormatFactory when I updated it to 2.70. I should not have done so.


Now after I restarted my computer, I got the "EVERYONE" group in and it is under Full Control with every box ticked except for the last one (Special). When I tried to delete that folder and the .exe file, this keeps popping up as i click "try again", only goes away when I click "cancel"

enter image description here

  • 1
    See the answer to this question - superuser.com/questions/111697/… – ChrisF Jul 8 '11 at 15:10
  • 1
    Boot from a Linux Live CD and delete it from there. – Moab Jul 8 '11 at 16:18
  • If you've found the solution please mark the corresponding answer as "accepted" using the green checkmark! – slhck Jul 8 '11 at 18:06
  • he's only 2 points away from his high score. help him out and click accept! – horatio Jul 8 '11 at 19:30

Download the following two tools from sysinternals (by Microsoft): Process Explorer and Autoruns.

Run Process Explorer and search for all handles matching "ask.com", close any and all processes it shows in the list. Then delete the folder.

Run Autoruns the Internet Explorer and Logon tabs find any futher references to ask.com or the toolbar. You may also want to check Services and Explorer tabs, but you'll want to be more careful in these two.

UPDATE Addressing commented issues: ProcExp is just like taskmanager, except better. When you find the program that is holding the folder/file hostage, end the task (right click on the process in the list and select Kill Process), then you try removing the folder again.

In changing permissions you specifically need to take Ownership of the folder and all subfolders and files. Right click on the Ask.com folder and select Properties. In the Properties dialog select Security and click the Advanced button. In the Advanced Security Settings dialog, select the Owner tab. Click either your account or Administrators (if your account is a member of administrators) and make sure you've selected "Replace owener on subcontainers and objects". Press Apply and let it process. You may also want to go to the Permissions tab and check "Replace permission entries on all child objects with entries..." and then press OK. Now back in the Properties box, select Administrators and make sure Full Control is checked and press Apply. Now press OK and try deleting the folder.

If the folder will not delete at this point, you can try using KillProcess.exe or another utility, but they'd be pretty much doing the same thing. I'd recommend not using any further utilities and simply slaving the HDD into another system and deleting the folder that way.

| improve this answer | |
  • 2
    The sysinternals tools are incredibly handy for cleaning annoying and persnickety software that fails to remove itself completely on uninstall, or for taming apps that like to take a greater chunk of your system for themselves than they deserve or than you wish to give them. – music2myear Jul 8 '11 at 15:29
  • If you do not have Simple File Sharing enabled, or if you're on a domain, you should be able to change permissions on the directory. Take ownership of the folder and it should allow you to delete it. – music2myear Jul 8 '11 at 15:49
  • There are always two possible reasons for this error: 1) a process is still using it, which the procexp and autoruns were to fix, and 2) the permissions do not allow it, which is what that comment above shows how to resolve. – music2myear Jul 8 '11 at 15:50
  • Okay I found the "updater.exe" running. it runs at startup, which my windows blocked it. which was why i could not find it in Process Explorer. Which way should I go now? – celyn Jul 8 '11 at 16:08
  • @celyn File -> Show processes from all users in Process Explorer – Darth Android Jul 8 '11 at 16:11

Running Safe Mode worked for me, the one file that causes the problem is the Updater.exe.

I'll never use Ask.com because of their underhand way to try get you to use their site.

| improve this answer | |

I was able to remove Ask.com Toolbar by just using the Add/Remove Programs control panel. There were two entries there, one for the toolbar and another for the "toolbar updater". Removing the first entry, the toolbar, uninstalls both the toolbar and the updater. The uninstallation did not delete the Updater.exe entry in the startup registry entry. I removed it manually with the free autoruns utility from Microsoft SysInternals.

This is a very rotten piece of malware. We really ought to clobber Ask.com for putting such a vile program on our PCs. I always say no to the Ask toolbar whenever I install software so I don't know how it got installed. I might have missed it this time. Although I'm not certain, I don't believe it's a virus (fingers crossed) because it was pretty apparent and not at all stealthy. I will be vigilant. It hogged my CPU, severely reducing its functionality, for most of the day before I was able to identify the problem with SysInternals Process Explorer. What was it doing running at max CPU all day? Was it sending the contents of my drives, keystrokes, screen, network packets somewhere? Something needs to be done to stop it.

| improve this answer | |

I would give this a read through. Dont expect an easy fix though, you are going to have to try many things to try and delete this folder, but thats the fun of windows.

Have you also tried logging in via "Safe Mode" and trying to delete it??

| improve this answer | |
  • Admintech: i'm reading that page. it's not easy though.. i'm not tech-saavvy person although I do know the more common things. but common to you may be foreign to me. no i have not tried "Safe Mode" yet. Does it help? – celyn Jul 8 '11 at 15:25
  • Safe Mode allows you to login with only the bare essential processes running, so this may allow you to delete the folder. That document is quite easy to follow (step-by-step and images) – admintech Jul 8 '11 at 15:26
  • yep easy to follow. thing is, i don't know which one to use! i'm thinking to "To Unset All Files in Folder as Read-only" – celyn Jul 8 '11 at 15:30
  • Yep OPTION TWO is the best one to go for, if not then try Option One on the files inside – admintech Jul 8 '11 at 15:35

I removed it fairly easy. I pressed Control+Alt+Delete, Selected task manager, selected processes, found process called update with ask.com in description. Right click it, select end process. Afterwards I was Able to delete folder with no issues.

Did this on Windows 7, should be the same on Windows XP.

| improve this answer | |
  • Welcome to Superuser! Salutations are not required, your username linking to your profile is already at the bottom of your potss. – Tobias Kienzler Jul 1 '13 at 6:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.