I want Chrome to be my default browser for everything. I don't want Firefox to open unless I want to use it explicitly.

  • I've tried telling Chrome to set itself as the default
  • I tried the instructions here and got as output:

    [georgemauer@ubuntu:~]$ sudo update-alternatives --config x-www-browser
    There are 2 choices for the alternative x-www-browser (providing /usr/bin/x-www-browser).
    Selection      Path                        Priority  Status
    * 0            /usr/bin/chromium-browser   40        auto mode
      1            /usr/bin/chromium-browser   40        manual mode
      2            /usr/bin/firefox            40        manual mode

Yet when I click a link in an empathy chat window or from the launcher it opens in Firefox! What gives?

I have rebooted many times and have been living with this for a week. Any ideas?

2 Answers 2


look at: ~/.local/share/applications/mimeapps.list

if the file is not there, create an empty one, then use the chrome feature to set it itself as default browser. If this not work, try adding this content. (check for the right .desktop file for Google Chrome)

[Added Associations]

[Default Applications]
  • 2
    Awesome, thanks...Now what the heck did I just do? Jul 9, 2011 at 15:40
  • 3
    You did what the browser should do by itself when you select it as default browser (or http protocol handler). Chromium fail to do this because is doing it through a Gnome 2.x application and Fedora is using Gnome 3. Also, since Chromium fail to register itself as an available browser, you cant select it as default from System Settings -> System Info -> Default Applications. In that file you can add as many references as you need like chromium-browser.desktop;mozilla-firefox.desktop and they will be available for use by Gnome as a fallback. Jul 9, 2011 at 21:10

For an old question, and up-to date answer:

xdg-settings set default-web-browser chromium-browser.desktop

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.