I have Windows 7 PC. When copying a movie file (mp4) from a DVD to my PC's hard drive, in Windows Explorer, I'm getting the error:

Invalid MS-DOS function.

The error message pops up, I cancel out, and the file is not copied at all. I have many other mp4 files on the DVD (I custom ripped it), which copied just fine.

What does it mean? How can it be resolved?


Ok, it seems the file may be corrupt at the end of the movie file, as it causes VLC to hang and crash.

  • Microsoft doesn't bother renaming ancient error messages? Commented Jul 30, 2014 at 19:09
  • @MichalKováč, I know right? Isn’t it something that even Window 10 still contains the string “MS-DOS”? Sheesh. I really can’t imagine why this message exists at all. The closest I can come to even attempting to explain it is that the file-io function uses interrupt 2F or something, but I highly doubt that is the case.
    – Synetech
    Commented Apr 16, 2017 at 16:58

5 Answers 5


As you confirmed that it is probably corrupt, that is good.

Usually it happens because the DVD is copy protected. There may be software that bypasses that, but it is doubtful someone would get that kind of help here as it is frowned upon.


I also received the "Invalid MS-DOS Function" error while copying files, but under a different circumstance: Windows 7, copying files from an SMB share on an Mac OS X Lion machine.

(This won't apply to you, but this is the only Super User question referencing "Invalid MS-DOS Function", so I mention it only in hopes of helping someone else!)

On the Mac, I opened a Terminal and ran ls -al in the affected directory, and noticed this:

drwxr-xr-x@  4 Blair    staff         136 18 Jan 21:52 Stuff

The @ mark is important -- it indicates that the file/folder has Extended Attributes.

This was the only folder I was having trouble copying; I checked all the other files and folders that copied successfully and discovered that they lacked extended attributes.

Running ls -al@ reveals what the extended attributes are:

drwxr-xr-x@  4 Blair    staff         136 18 Jan 21:52 Stuff
        com.apple.quarantine            48

This is the quarantine attribute used by the OS to mark files downloaded from the internet as "potentially unsafe".

Believing the attribute to be playing foul with Windows, I decided to remove it. This answer shows how:

xattr -dr com.apple.quarantine Stuff

I returned to the Windows machine and started copying the folder again -- it worked without a problem.

  • 2
    Absolutely the exact problem I had. Spot on, to notice the quarantine xattr. Great post! +1!
    – user16511
    Commented May 2, 2012 at 15:55

You can delete the from by openning command prompt (windows start->cmd, click enter) then run: del \?[filename+path]


Though, I knew this was an old or probably a solved problem but here is my addition to the solution.

  • Click Start, type regedit in the Start Search box, and then press ENTER

  • Locate and then click the following registry subkey:


  • On the Edit menu, point to New, and then click DWORD Value.
  • Type CopyFileBufferedSynchronousIo to name the new entry, and then press ENTER.
  • Right-click CopyFileBufferedSynchronousIo, and then click Modify.
  • In the Value data box, type 1, and then click OK.
  • Exit Registry Editor.

Then copy.


I am late to this, but if someone is still looking for a solution: Copy command from the command prompt worked for me.

  • 1
    …or just try it again from Explorer.
    – Synetech
    Commented Apr 16, 2017 at 16:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .