When I click on a PDF link in Chrome, it opens automatically inside the browser window. How can I get it to download instead and open with an external viewer?

Update: I implemented djhowell's solution but Chrome still seems to be handling PDF files differently from regular files. When I click a PDF link it opens in Adobe Reader, but normally files download to a folder first.

I also find it weird that this is controlled by Reader and not Chrome. Are there not any file-type controls in Chrome anywhere?

  • I checked too, it seems that Chrome has tendency to choose what to do with files for you... I'm actually surprised there is not "file association" to be found, to choose the program/plugin to use for a particular extension. – Gnoupi Aug 27 '09 at 18:50
  • 1
    I find even such topics in the Google Group for Chrome : groups.google.com/group/chrome-google/browse_thread/thread/… , people who would like to switch to another viewer, and can't.. No answer.. – Gnoupi Aug 27 '09 at 18:55
  • Added an update but the conversations in the Chrome support forums don't seem encouraging. – djhowell Aug 27 '09 at 19:28
  • Please consider my answer, I think it cover your needs a little better, if so, you should change your selection of the right one – Rafareino Aug 21 '15 at 16:09

14 Answers 14

up vote 73 down vote accepted

You can disable the Adobe plugin in Chrome, which will force Chrome to download the PDF.

It's under Settings > Privacy and security > Content Settings > PDF documents. Or enter chrome://settings/content/pdfDocuments in your browser address bar to go straight there.

  • 1
    That's the right answer! – nickd Jul 22 '10 at 10:09
  • 8
    a probably faster way to do the same thing: go to chrome://plugins (in firefox, that would be about:plugins), and disable the acrobat reader plugin – Babu Aug 23 '10 at 13:24
  • As I mentioned in my answer I don't have Adobe Reader installed any more but this looks like the best solution for those that do. – DisgruntledGoat May 20 '11 at 11:55
  • 2
    In version 12 of Chrome, I see Chrome PDF Viewer listed as a plugin. Disabling this does what is asked, downloads the pdf to a file. – KeithB Jun 19 '11 at 15:18
  • 3
    The chrome://plugins page isn't available anymore in Chrome. – Royi May 26 '17 at 10:40

browse to chrome://plugins and disable Chrome PDF Viewer

  • This seems to be the only answer that solves DisgruntledGoats "Updated" problem (aside from Doug's basically identical answer posted a day after this one). It's definitely the one that helped me! – Fred Hamilton Jan 21 '11 at 16:43
  • This worked for me. Thanks! – Tim Perry Jan 28 '11 at 3:29

Are you using Adobe Acrobat/Adobe Reader to display the PDFs? If so, it is probably Abode's behavior you need to modify.

Here are the steps I had to take:

  1. Open Adobe Reader
  2. Edit menu, Preferences
  3. Selcet Internet from the Categories list
  4. Uncheck Display PDF in browser
  5. Press OK

If you are using another application to view PDFs the steps are likely similar.

Re: Update

By any chance do you have both Adobe Reader and Adobe Acrobat installed? You may have to repeat the above steps in the other application.

Chrome is a little weird in that its default behavior is to download everything and make you open it yourself. When you click a PDF link do you see the filename in the "download bar" along the bottom of the window? If so, try right-clicking on it and un-check "Always open files of this type" if it is checked.

  • beat me by 50 seconds, CG :) – Molly7244 Aug 27 '09 at 17:39
  • Thanks for the answer but it hasn't worked 100%, see update. – DisgruntledGoat Aug 27 '09 at 18:37
  • 1
    the issue of downloading the file to a local folder first seems to related to this thread: superuser.com/questions/30823/… – Molly7244 Aug 27 '09 at 19:30
  • To answer your update: No, I don't see the file in the download bar, the PDF just opens when I click it. The behaviour you describe is what I want to see, i.e. the same as all other files. – DisgruntledGoat Aug 30 '09 at 17:19

In Google-Chrome: open a new tab, go to about:plugins and disable "Chrome PDF Viewer". This seems to have done the trick for me.

Kind of sorted this; I uninstalled Adobe Reader and installed SumatraPDF instead! Much better and lightweight app.

Another option is that Chrome, instead of downloading PDF's, launches them in the system defined PDF Reader.

The way to stop it is in the Content Settings in Chrome's Settings:

enter image description here

that depends on your default PDF reader, for Adobe try this:

Edit > Preferences > Internet

clear the box Display PDF in Browser

How about pressing CTRL + S and saving the file after it opens it? Works ok if you are not into downloading a lot of PDF's

  • 1
    This is an old question and I don't think that worked at the time. The only problem with your solution is that (in my experience) large PDFs take a long time to load in the browser (not including download) and sometimes don't work. – DisgruntledGoat Jan 9 '14 at 10:47
  • it still doesn't seem to work, for example, if the PDF is password protected – cnst Nov 28 '15 at 5:01
  • this will not work if the pdf is not served as a static resource, but rather through some other kind of request. Then chrome will say 'file not found' when you try to save. You may instead choose to print it, and in the print-dialog choose save as pdf, but this is very cumbersome and unintuitive. – Superole Aug 23 '17 at 10:57

According to Adobe's page on displaying PDFs in various browsers, in order to have Chrome not open the PDF within the browser, after you've opened a new tab to chrome://plugins, you'll need to shift-click "Disable" on the currently enabled plug-in to display PDFs.

Otherwise, it will still open in the browser, it just uses different plug-ins to display it.

To have Chrome download PDFs instead of displaying them in the browser, shift-click Disable for the currently enabled viewer. This leaves both viewer plug-ins disabled so the PDFs won't display in the browser.

Once you do this, it will download the PDF, instead of opening it within Chrome.

Edit: as pointed by @Tanath in the comments, this method not seems to work anymore!

To me seems that the desired behavior was to be able to save the files instead of open them in another application, so, I think a more accurate answer should be:

Press and Hold down the Alt (Meta) key in your keyboard while you click in the PDF link.

  • This isn't working for me. Even with alt pressed it's automatically opening them. – Tanath Dec 22 '16 at 15:24
  • Me neither, probably removed! I will edit my answer to make it clear. – Rafareino Jan 18 '17 at 13:30
  • Thanks so much...had to try all the answers till I landed on this....Chrome is so &*#^@$ up in some ways - taking away control over unloading of tabs from extensions, and now this...how many times will they change stuff around...aaaargh – killjoy Sep 27 '17 at 16:12

As of April 2017, (Google Chrome 57.0.2987.98) the chrome://plugins page has been removed. Google has been moving everything to the settings page. This answer has been said in several different ways above, but the fastest way to shut it off is to go here:

chrome://settings/content/pdfDocuments

There is a single toggle "Open PDFs Using a Different Application". Turn this on. PDFDocuments toggle

Ref: What Happened to chrome://plugins in Google Chrome?

Ref: Depreceate chrome://plugins (on bugs.chromium.org)

The following worked for me:

  1. Go to chrome://settings/
  2. Click + Show advanced setting
  3. in Downloads

    3a. check 'Ask where to save each file before downloading'

    3b. click on the button Clear auto-open settings

Note: 3b is fundamental to override the fact that PDFs are handled differently from other files.

Background: this happened to me as well because once I downloaded a pdf file, clicked on the small arrow next to the file in the download bar at the bottom, and choose 'always open with system viewer'. Since then, PDF files were saved in the "Download" folder and opened directly.

  • 1
    This didn't work for me. Clicking PDF links still automatically opens in my PDF viewer, when it used to automatically save, as desired. I never chose always do this for these kinds of actions. – Tanath Dec 22 '16 at 15:16
  • For me it worked after I have restarted Chrome. – pietro Dec 24 '16 at 9:19
  • 1
    That didn't help me, sadly. – Tanath Dec 24 '16 at 14:29

The actual problem is not that you have a PDF extension, it is that at one point you checked the box that said "always open with system viewer" it is very easy to do by mistake.

To fix this (for Chrome) you need to go into settings and in the search bar, search: "auto-open" then under the downloads section you will notice a button that states "Clear auto-opening settings", click that (a couple times, just to make sure) and that's it, now the files will just download and be sitting in your downloads section/file. Screenshot of Chrom Settings_Clear Auto-Open

  • 2
    This duplicates another answer and adds no new content. Please don't post an answer unless you actually have something new to contribute. – DavidPostill Jan 20 '17 at 21:13

As per the new settings in the Chrome Version 59.0.3071.115 (Official Build) (64-bit):

Settings> Advanced Options> Privacy and Security (Look under this)> Content Settings> PDF Documents> Open PDF using a different application

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.