1

Whenever I run cmus on Terminal.app, it insists on changing the terminal title to the currently playing song. And since cmus is in a separate tab almost all the time, it looks quite ugly:

Ugliness

And when I quit cmus, the title stays like this. The only way to get it back (AFAIK) is to close the tab and open a new one to replace it.

Is there any way to keep cmus from changing the terminal title altogether?

5
  • 1
    PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME%%.*}:${PWD/#$HOME/~}"; echo -ne "\007"' Jul 10 '11 at 3:23
  • @Ignacio: That would be fine, if I wanted all that in my terminal title. Is there any way to get it back to where there is nothing in my title, except for what Terminal.app itself provides?
    – Wuffers
    Jul 10 '11 at 3:25
  • Dunno. Try putting nothing between the ; and the \007. Jul 10 '11 at 3:29
  • @Ignacio: That works, but I'm really looking for how to keep cmus from setting it at all.
    – Wuffers
    Jul 10 '11 at 3:34
  • That's why I didn't pose it as an answer. Jul 10 '11 at 3:48
0

Run $ cmus and enter the command

:set set_term_title=false

Exit cmus and it will not change the title anymore.

cmus with set_term_title = false Image: cmus with set_term_title set to false

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.