43

I'd like to know if a way exists to make PHPMyAdmin show entire fields in the table browsing tab. Right now I have a TEXT field and I can never read the entries in their entirety.

How can I do that?

4 Answers 4

55

Older versions of phpMyAdmin (when the question was asked)

Once you have the query results on the page there are a couple of options. In the left-most header column you should see a link something like <-- T --> If you mouse over that you will see that it toggles "full texts".

You can also click on "Print View (with full texts)" at the bottom of the results when you are viewing the partial texts. This option disappears (and is actually the default for Print View) once you have clicked the link mentioned above.

Current Versions

Click on +Options and you'll find a "Full Texts" radio button.

3
  • 1
    My pleasure! Glad to help! Jul 12, 2011 at 19:11
  • Is there anyway this can be done in command line?
    – roopunk
    Feb 8, 2016 at 6:48
  • more modern, click gear top right, change "Limit column characters" field May 8, 2023 at 0:43
20

Click on + Options

Select Full texts and click Go

Example image:

PhpMyAdmin Full texts

3
  • Thanks. The selected answer definitely needed a screenshot.
    – FirstOne
    Aug 17, 2018 at 18:34
  • The Options button is located right above the query output rows.
    – Gruber
    Nov 11, 2022 at 18:41
  • "+ Options" is above the results and below the query itself
    – Eugene
    Sep 18, 2023 at 15:03
4

There is another permanent solution if you could able to access the configuration file config.inc.php. The solution is to change LimitChars property from its default value 50 to any desired value.

In 16.04 the configuration file may be found at /etc/phpmyadmin/config.inc.php and I edited it like the following:

...
/*
 * Directories for saving/loading files from server
 */
$cfg['UploadDir'] = '';
$cfg['SaveDir'] = '';
//Add the following line
$cfg['LimitChars'] = 128;
...
0

phpMyadmin is limiting the number of characters outputted. As mentioned by SaidbakR you can change it permanently but you do not need to go into configuration file. At least this is the case in version 4.9 that I am using.

Just go to Settings > Main panel > Browse mode and change the value of "Limit column characters" to a desired number. I put 1000 for example.

Image of the place where you can find the setting

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .