14

When marking several music files in finder, and opening them in VLC media player, the player starts playing the last file and stops. What's the trick to make it play the files in the selected order?

Or at least the alphabetic one...

4
  • Did you make sure the 'Random' isn't ticked under the Playback DDW? worked for me! good luck dog.
    – user302349
    Feb 22, 2014 at 12:40
  • 2
    If someone like me stuck in 'Random' order - just press CMD+Z and it will disable random order.
    – whitesiroi
    Nov 7, 2015 at 6:39
  • Dino's answer worked for me (unchecking the check box "Play files randomly forever" in preferences). Sep 5, 2019 at 21:41
  • What is "finder"? Some Mac thing? Sep 5, 2019 at 21:44

13 Answers 13

6

It won't do it by default - what you need to do is drag them all in, and then select the first one in the playlist viewer.

Since I posted this 9 years ago things have changed - just unchecking the "random" box under playback will now work - looks like they fixed it around 2014.

4
  • Can I change the default? This workaround you suggested is natural, and clearly the one I'm using - but it is still not the best you can hope for :) Thanks anyway!
    – Dror
    Jul 11, 2011 at 13:17
  • It doesn't look like you can change the defaults - the VLC documentation wiki at wiki.videolan.org/Documentation:Documentation certainly doesn't give it as an option.
    – Rory Alsop
    Jul 11, 2011 at 13:32
  • 4
    Two years later, and this "feature" still isn't resolved... Pretty annoying imho.
    – Matthias
    May 9, 2013 at 9:33
  • You need to make sure play random button is |"disabled" in the player bottom bar Dec 10, 2020 at 1:06
8

Select all, right click, select: sort by|name|ascending. The easiest way I have found.

3

This is a simple issue to solve:

  • Ctrl + P (or menu ToolsPreferences)
  • Click 'Audio'.
  • At bottom left of the dialog box, click 'All' (near Show settings).
  • In the pop up list, click 'Playlist'.
  • On the right hand side, uncheck the first box entitled 'Play files randomly forever'.
  • Click Save.
  • Close VLC and reopen, et voilà!
2
  • This solved a problem I had (caused either by an accidental change or updating to a new version of VLC media player). In term of discovery, the crucial thing is the lower left 'All' (bullet point 3). Sep 5, 2019 at 21:37
  • It was probably accidental: the 'Random' icon (the last icon, 9th, in the icon group at the left) in the main interface seems to control this setting. In other words, clicking the icon is an easier way to change the setting (but it is easier and more explicit to see the actual setting in preferences). Sep 5, 2019 at 22:18
3

OK, if you click on the "title" bar just right above the song names, it will automatically sort from then on.

However, it seems like it starts playing at the last played track number instead of starting at the first one. But at least it's in order now when I open it.

1
  • That is the answer to a problem I had with VLC forever (and I resorted to Winamp to do file sorting): To sort the tracks by path and filename, right-click on the title bar and add the field "URI", which gives the path to the media. Then you can sort by path and filename.
    – Ian
    Aug 15, 2020 at 11:49
1

I found the bugger. Just disable the option "Pause at the last frame of the video".

The English tooltip mentions that this option will pause the reproduction after each item of the playlist.

0

Go to View User. Highlight all the tracks. Then right click. It gives you options to order them by; alphabetical, track number etc.

0

I tried a solution for VLC media player playing disorder and will it explain with an example. Suppose you downloaded a movie divided in 12 parts, namely 1, 2, 3, etc. If more than 9 parts rename all as 01 instead of just 1 likewise. Save them in a separate folder. When you open the folder, go to view tab and choose details so that files will be seen as 01, 02... from top to bottom.

Now first open the VLC media player programme. Go to the media menu, click and open "Open File". Browse and choose the saved folder on the appropriate drive. Click on the folder. You will see all files lined up as 01, 02, etc. from top to bottom. Select all files at once by selection 01 and the Shift key and dragging till the last imp. Note: never choose 12; first start with 01 and go downward, selecting all files at once and press Enter.

1
0

I think that the idea is to try to make it simpler. Of course that once in VLC media player, even given the case that it started wrongly, you can change the order of the play list and start it over.

I think the ideal would be to find a way in what you could select a bunch of songs in your browser, hit Enter and have the songs playing in the right order (the one they were on the folder).

I've been annoyed with this for years.

Open VLC media player first and then drag the songs works, but that definitely involve more steps than a simple Enter.

1
  • How does this answer differ from the accepted one?
    – Insane
    Oct 25, 2015 at 22:59
0

Just go to menu ViewPlaylist → right click on the empty area → choose Advanced Open... → click Add... → choose your files → click Select.

That's all :D

0
0

Whatever I did, the album wouldn't play audio tracks in order, but I finally worked it out.

If you right click on the track and "add to playlist", whatever the logic is for the play order I can't work it out.

Drag each file into the VLC media player window, and it plays in the order dropped in. If only UltraPlayer could play flac, life would be much simpler.

0

This bugged me so long, but now I found the best way for me.

Select the directory of the album in file manager by right clicking it. Select 'Add to VLC media...' in the popup menu. It plays songs in alphabetical order!

If VLC is already running, open menu MediaOpen Folder... and select the folder of the album.

Of course, this doesn't work for a selected number of songs in a directory... ;(

0

In the playlist, try to left click on "Track number" and drag it over to the left. It opens in numerical order every time.

0
-1

I wanted to play an album in order of track number, and I worked out how to play it any order you want:

Go to menu ViewPlaylist. Right click any of the panels that say Track, Duration, etc. Choose the list view you want to see, then click on that list option to put the tracks in that order (I wanted track order).

Alternatively, you can drag tracks into any order you want.

Finally, just double click the top track to start playing from the top of the list.

Not the answer you're looking for? Browse other questions tagged or ask your own question.