I'm using nfs to mount the folder /mirror from a server onto a node.

This works, except on the node the user and group are displayed as "4294967294".

On the server: ls -al ./ displays

-rw-r--r--  1 cu cu    0 2011-07-11 15:08 test1
-rw-r--r--  1 cu cu    0 2011-07-11 15:08 test2

whereas on the node

-rw-r--r--  1 4294967294 4294967294    0 2011-07-11 15:08 test1
-rw-r--r--  1 4294967294 4294967294    0 2011-07-11 15:08 test2

I have usermod and groupmod the username cu to have the same numbers on the node.

On the server: id displays

uid=1021(cu) gid=1007(cu) groups=1007(cu),109(admin)

on the node

uid=1021(cu) gid=1007(cu) groups=1007(cu)

I'm stumpeed as to what the problem could be.

I should perhaps add that the home directory is /mirror/cu (so that the users share the same account when mounted). Not sure if thats relevent though...

My /etc/exports file (on the server) looks like this

/mirror *(rw,sync) 

and I do the mount (on the node) with

sudo mount server:/mirror /mirror
  • 1
    I would flag this as a duplicate of serverfault.com/questions/98741/… but seen as its on another site I can't... hmm... – PriceChild Jul 11 '11 at 15:34
  • Yes, didn't see that one (didn't google the actual number - I thought it was a random number!) Thanks – Tom Jul 11 '11 at 15:38
  • Apparently its an overflow of -2. There's no accepted answer in that link but at least lots of options. Common amongst google seems the idea that its an imapd problem, but also that its several problems in one. Before you do anything else I'd suggest a reboot (or restart of the involved services) 'just incase' some config somewhere hasn't been taken up :-P – PriceChild Jul 11 '11 at 15:41
  • Thanks @PriceChild: this answer worked for me: serverfault.com/questions/98741/… – Tom Jul 11 '11 at 15:54
  • Aha which then links to serverfault.com/questions/223408/… ! Awesome. Meh as I'm not sure this question can be marked as a duplicate, post the result in an 'answer' and accept it yourself tomorrow :-) – PriceChild Jul 11 '11 at 15:56

As @PriceChild notes, this question is a duplicate.

However, no answers were accepted to that question. I tried this answer first, namely adding

-o vers=3 

to the mount command, and that worked for me.

The rationale for this (using version 3 of NFS rather than version 4) is that

NFSv4 doesn't use UID/GIDs anymore. There are quite a few significant differences between NFSv3 and v4; security is one of them.

Note: I was satisfied with this fix and I didn't get to the root of the problem. If you want to take if further, the aforementioned links should help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.