2

I have an Ubuntu 10.04 desktop (johndoe-linux) and a Win7 machine (johndoe) and I have Samba set up on Ubuntu to give full access to all users to a workspace. This is my smb.conf.

[workspace]
    path = /local/mnt/workspace
    writeable = yes
    guest ok = yes

Other users with identical Win7 machines are able to access my samba dir by going to Start->run and typing \\johndoe-linux\workspace. When I try from my Win7 machine, it instead prompts me for a username/password. Neither my windows, linux or smbpasswd work here. No other users get this username/password prompt and the directory immediately pops up in File Explorer.

The only difference I can think of is that my Win7 machine has the same username as my Ubuntu machine. I login to both with the same username "johndoe", but the domains and passwords are different.

Why is it prompting only me for a username/pw? Is there some Win7 security feature I need to disable? Any help would be greatly appreciated. Thanks.

  • Weird.. Do you have any cludes from logs? Perhaps under /var/log/samba ? – James T Snell Jul 11 '11 at 23:19
0

By default when connecting to a remote computer in Windows, it will try to log into the remote system using the same username and password as you are using locally when you logged in. If the user name isn't found on the remote system it can try the guest account, but if the username does exist but the password isn't the same it'll get confused and ask you to log in manually to resolve the situation.

Either rename one of the accounts or log in explicitly. You may need to specify the Samba machine's computer name as the domain name with domain\user in the username field on the prompt dialog (with the login on the remote system) to get it to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.