I have an AMD system - It is currently running with 1 stick of 2GB ram. Lately, I added another identical 2GB stick to it. However, Windows 7 is not booting with 2 sticks of RAM. It will boot with either stick of ram, but not both together. Ubuntu loads fine (from CD). I have tried reinstalling windows, but it still doesnt load. It hangs at the 'starting windows' screen.

I am baffled what could be the problem, given these are identical sticks of ram! I have another pc as well, and haved swapped the RAM. The other pc works fine with these 2 x 2gb, but this computer still wont boot with the other' pcs 4gb ram as well.

Any ideas what might be the problem?

System description below:

Asrock M3A UCC AMD Athlon II X4 645 (3.1Ghz) 2x 2GB RAM (PQI, DDR 1333) 1 x 500 GB RAM

I've also tried resetting the BIOS defaults. The only change I've did was change SATA mode to AHCI. Bios was updated to latest version. I have also tried replacing RAM with another pair that are working on another computer fine, another working PSU.

Also, I've changed the motherboard with a brand new exact model like it was, as I was pretty sure it was the motherboard - But again, same problem persisted!

Any ideas??

Update - I tried changing SATA mode back to IDE, as that is the only change I did in the bios, and strangely enough, it worked ! Windows Install screen loads, though I havent installed the OS yet but will do soon and post updates. RAID mode also works fine. Any clues why this might be linked with amount of RAM? totally baffling to me !

Update 2 In IDE mode, Windows Installation is asking me for further drivers, and no drives are being detected! This also happens in RAID mode, although I know raid should require additional drivers - IDE mode shouldn't.

  • computer setup is standard, and is not overclocked. – Karl Cassar Jul 13 '11 at 12:33
  • If Ubuntu detects both sticks then you are probably running 32 bit windows 7? try 64bit for 4gig and more support. – Jiraiya-Sama Jul 13 '11 at 12:56
  • It's not even loading the install screen of Windows. Previously it had installed Windows 64-bit, which was installed when only 2GB of ram where in place. – Karl Cassar Jul 13 '11 at 13:04
  • Serial port kernel debugger time! – ta.speot.is Jul 13 '11 at 13:12
  • are you trying to re-install windows? or is the current installation not booting? – Jiraiya-Sama Jul 13 '11 at 13:31

This sounds like a motherboard issue. It's possible that the RAM and the motherboard are incompatible.

One possibility is that you have a so-called "triple channel" motherboard, which would mean that installing exactly two RAM sticks could result in system instability. If that's the case, you'll need to install a third RAM stick to get the system to work properly.

Have you checked the motherboard's manual for a list of compatible RAM? It's unlikely, but possible, that you've overlooked something like the RAM's speed, or type, or some other characteristic that would make this particular model unfriendly toward your motherboard.

If you think you have defective RAM sticks, you could also try running the Windows Memory Diagnostic. Run that diagnostic by booting from the Windows 7 installation disc, or follow these instructions.

Good luck!

  • I've ran MemTest86+ for a whole night, everything is fine. I've also used another pair of 2GB DDR3 sticks which are installed on another computer that is working fine with Windows 7. The motherboard is a dual-channel motherboard - It has four slots in all, two color coded blue, and two white. Manual clearly states that a pair of RAM sticks must be installed be installed either both in the blue (A1,B1), or white(A2,B2). I've tried all combinations, even with A1,A2 maybe the problem is with dual channel. Just 1 stick of RAM works, and they're identical, so I dont think its a RAM issue! – Karl Cassar Jul 13 '11 at 13:03
  • Also, note that the computer works fine with just 1 stick, and loads windows as well! It's 4GB that dont work. I also tried 3 sticks (6GB), but doesnt work. I've changed motherboard today to one brand new, same model - And still same problem! – Karl Cassar Jul 13 '11 at 13:04
  • Wow - you've really got an unusual problem here. Sorry, man, this sounds like a huge exercise in frustration. You have to start considering very unusual scenarios at this point. Maybe you have a defective Windows 7 installation disc? Maybe you've been lucky enough to get two defective motherboards? Good luck. – Mantis Jul 13 '11 at 13:06
  • @Karl: Is your RAM on the manufacturer's compatibility list? I'm thinking that it's some sort of really unusual compatibility quirk. The overwhelming majority of the time things work, but if either the MB or RAM (or both) are operating at the edge of the specs, things can break. Finally, try manually setting (relaxing) the RAM timings in the BIOS. There's a possibility that the MB doesn't correctly read SPD timings and you'll need to override by hand. – afrazier Jul 13 '11 at 13:26
  • Just a strange thought which occurred to my mind right now - I tried change the SATA mode from AHCI to IDE, and windows install is now loading! I also tried changing it to RAID, and it works as well. It does not work with AHCI! I also tried trying to load the install screen of windows without any hard disk attached, maybe the HD was the conflict, but still wouldn't load in AHCI mode. I want to use the benefits of AHCI, which as far as I know RAID-mode is the same? However, RAID requires extra drivers to install, which I would prefer skipping! What could this SATA-mode do with amount of RAM?? – Karl Cassar Jul 13 '11 at 13:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.