I am running an HP laptop (compaq 2510p) on Windows 7 32 bit that has a gigabit NIC. I am on an internal work network accessing a share on a server that also has a gigabit NIC. When I try to download an installation file I get a max of 200 kb/sec while my co-worker, who is running off of the same local switch in out office, gets at least 3-6 mb/sec transfer. My CPU and RAM stay below 50% and my network monitor in performance monitor stays below 5%. I have tried the same ethernet cable as my co-worker and he has no problems but I still do.

Edit: I am in the IT staff so I have access to change things, but I just started so I am not familiar with the network or how this laptop is set up. It was used by the person I replaced since he left a couple of months ago so I do not know what is left on here. I believe the network is 100MB/s but that my NIC is Gigabit. Basically since I am new to their setup I am just looking for general places to look since my boss is busy and isn't available very much.

Fixed: Turns out it was the card's speed option. It was set to 100MB/s full duplex but changing it to auto negotiate fixed it.

  • Is your co-worker also using Windows 7? – KCotreau Jul 14 '11 at 14:58
  • Maybe your problem is Hard Drive(HDD) Writting. Your co-worker is using the same machine model as you? – Diogo Jul 14 '11 at 15:00
  • Yes he is, a desktop but same OS and same speed NIC. – Mobojo Jul 14 '11 at 15:08
  • No, he is on a desktop with the same OS and NIC speed though. When I copy a 7 mb file from my flash drive it copies instantly. – Mobojo Jul 14 '11 at 15:11
  • To be clear here, are you referring to megabits (Mb) or megabytes (MB)? With those numbers, even the 3-6 mb/sec transfer is still very poor speed. – John T Jul 14 '11 at 15:36

I would try checking with your IT technician or Network Administrator before troubleshooting your connection with a coworker. They may be able to offer you a better answer much faster than your troubleshooting will. Typically the IT department does not like it when employees take things into their own hands as it causes more work in the end.

The causes could be many things, my best guesses would be:

  • Bad NIC driver.
  • Your MAC address may be throttled at an intermediate level due to your past internet usage (ie. Access-level switch, check with IT) despite the download being internal.
  • Bad switchport
  • Third party software on your machine may be inspecting traffic which can lower performance.

To be quite honest, both transfer rates are fairly poor for a gigabit network. 10M/s and upward is average.

  • The thing is I am one of the IT technicians, but I just started last week so I am not too familiar with out network and my boss isn't too sure what is wrong and left it to me to find out. The laptop I am using was used by the previous IT support member and wasn't wiped so there may be random things left on it. I just tried updating the driver with no luck.Basically I am just looking for things to try before I bury myself. – Mobojo Jul 14 '11 at 16:34
  • @Mobo: try other PCs on that same cable, try a different NIC card, try spoofing the MAC on your current NIC card, try plugging into a different switchport. Let me know how you fair. – John T Jul 14 '11 at 18:00
  • Turns out it was the connection speed setting. It was set to 100MB/s full duplex, but changing it to auto negotiate seems to have fixed it. – Mobojo Jul 15 '11 at 14:13
  • 200k/s is still ridiculously slow for 100MB full duplex. Glad you figured it out though :) – John T Jul 15 '11 at 14:18
  • My guess is that something about setting it to something besides auto neg messed with some setting somewhere, odd issue though. Thanks for the help. – Mobojo Jul 18 '11 at 13:03

I believe you may be having may be having issues with your computer trying to connect to a network location that is no longer there. This causes time-outs and slowness. I fixed this issue on a computer just yesterday.

Try the following:

  1. Run CCleaner, which will clean out recently run caches (like the list of recently opened items in MS Word). While you are there, you could also run the registry cleaner for good measure.
  2. Check to see if you have any mapped drives that do not respond when you click on them. If so, right click, and disconnect them.
  3. Clean out any network shortcuts to non-existent server locations. In Windows 7, it is located here:

C:\Users\%userprofile%\AppData\Roaming\Microsoft\Windows\Network Shortcuts

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.