The question says it all, but more detail follows ;)

I've got a new computer that runs Windows 7 64-bits (Home Edition) and I'd like to connect it to my wireless home network (Sitecom wireless gigabit router 300N wl-352 v1 002) with a Sitecom wireless USB micro adaptapter 300 wl-352 V2 001.

After installing the router (i.e. connected to the modem and power) and ensuring that wireless is indeed enabled, I've installed the driver of the USB adapter on the new computer described above. After the installation (drivers and utility on CD) completes successfull I rebooted my computer and inserted the USB adapter. After discovering the right network and connecting to it using the network key, a connection is succesfully made. (Using the Sitecom 300N USB Wireless LAN utility).

In the LAN utility I can see that the signal strength is approximately 50% and connection quality is approximately 80%. Judging from these numbers I assumed that all was fine and started to use the connection (reading news on nu.nl, a dutch news site), but noticed that the connection was lost several times in a very short time span, but each time the connections was resumed, resulting in the 50/80 percent numbers described above. However, the website was not loaded completely and often a timeout would be reported.

When inspecting the drivers through Device Management (Windows' Apparaatbeheer in dutch) there were no errors/warnings; everything seemed to be in order.

In an attempt to solve this, I downloaded the latest drivers for the USB adapter, but the problems remained.

Finally I tried to connect the computer with a Siemens Gigaset USB Adapter 108. This process was a troublesome since I had to download a driver (from the site above) and tell Windows (7) to use the Windows Vista driver when installing the new hardware, since there is (was) no Windows 7 driver available.

This resulted in a usable connection, although not very stable when reconfiguring the router. Which took the form of selecting a different wireless channel on the router, even using the Sitecom utility mentioned above to check if there were other networks communicating on that channel (and thus picking a channel that was not used by other networks). Again no result when changing back to the Sitecom USB adapter. Note that this means (I think) that I could use the internet connection with the Siemens adapter, meaning the problem was not in the router.

So: How to get wireless working (properly) with Sitecom Wireless USB micro adapter 300N on Windows 7?

PS Sorry, but should be able to post one link, while I had links in place for the USB adapter, router and the siemens adapter in place as well, but I'm not (yet) allowed to post these... (The site says I can post one link, but only when no links are present will it allow me to post the question...)

3 Answers 3


I quess your problem is already solved. But still i post this because i had the same problem and maybe also some people in the future. I found the next solution and it worked for me. The chipset in the sitecom usb adapter is manufactured by ralink. Sitecom doesn't deliver the proper drivers for windows 7 on their website. Ralink does. Go to ralinktech.com and go to their support page and download the driver that says USB(RT2870/RT2770/...).

  • 1
    Thank you for your answer! I'm currently not in a position to test your solution, I'm not using the adapters anymore. If others think this is the proper answer, I'll make this the answer.
    – Timo
    Oct 25, 2011 at 11:54
  • The solution provided by paa with regards to Ralinktech is absolutely correct. I tried it myself. Be sure to download the drivers for the right OS. After that it's just a simple installation wizard to get the WiFi working.
    – user324668
    May 18, 2014 at 13:27

My final attempt was to run the Sitecom 300N USB Wireless LAN utility in compatibility mode, using Windows XP SP3 and "always as administrator", which apparently cleared the issue. However, I'm not sure if this is really the way to go.

I've received a suggestion that Windows 7 might not give the USB port with sufficient continuous power for the dongle to keep working, which should be adjustable in somewhere (but I'm not sure where).


I had the same problem. It may be a question of compatibility of your USB adapter with the router (for example if your router is "b" or "g" based, and you have an "n" adapter).

If so, you can solve the problem by changing the wireless mode.

  • Go to Device Manager → Network Adapters → "your usb adapter" → Properties → Details (or something) → Wireless Mode.

  • Change it from 802.11n to 802.11b (or 802.11g if you have such a router).

It should help.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .