I'm trying to get ZSH as my default shell, I've installed using the installer from the oh-my-zsh project and it all installs fine, but I cannot change it to be the default shell:

When I echo $SHELL it gives "/bin/zsh",

  • However ps -p $$ seems to suggest bash (although I have seen this suggest zsh even when it isn't)

  • I've also tried changing it in the Accounts → Advanced settings → Startup shell and in the Terminal preferences.

  • Using chsh -s /bin/zsh says "No changes made..." i.e. it also thinks zsh is in use.

I can switch to zsh manually by typing zsh or /bin/zsh, just can't change it to default and that is rather annoying.

Any ideas?

closed as too localized by Nifle, Gilles, studiohack Aug 1 '11 at 1:11

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

migrated from stackoverflow.com Jul 16 '11 at 3:28

This question came from our site for professional and enthusiast programmers.

  • 1
    Try echo bash=${BASH_VERSION:-not running}, zsh=${ZSH_VERSION:-not running} to find out for sure what you're running. – Gordon Davisson Jul 16 '11 at 3:55
  • What version of Mac OS X are you running? What does id -P report at the end of the line? Did you really install zsh at /bin/zsh? Any chance you have something in a shell startup file that invokes bash? And, sorry to ask this, but did you know that changing your default shell will NOT automatically take effect in already-open Terminal windows? – Spiff Jul 16 '11 at 7:15
  • Spiff, yes the computer had been restarted multiple times, and the end of that line was regarding screen sharing... Thanks for your response though! – Chris Edwards Jul 16 '11 at 9:52
  • It could be that you hadn't installed git when you ran the oh-my-zsh installation script. The error message is inconspicuous - in comparison to the flashy "oh my zsh is now installed" which you get even if it wasn't. That lion comes with zsh installed just added to the confusion... – Kolja Mar 3 '12 at 16:46

Worth pointing out that you have to actually add whatever new shell you've put in that isn't there on a vanilla box to the /etc/shells file (or somesuch similar)... You didn't post the whole text from your chsh attempt, and the snippet you did put down at least leaves that door open.

Good Luck.

  • Thanks for your response! That was all I was getting from the chsh, its had been solved now anyway, I shall post the answer now. – Chris Edwards Jul 16 '11 at 9:53

Very strange guys, but I installed some software updates and after that restart (the computer had already been restarted multiple times) it just worked...

Very odd but at least there was nothing actually going wrong...

Thanks to everyone who responded!

  • 3
    Please mark this answer accepted once it's possible, so the system can consider this question answered. – Daniel Beck Jul 16 '11 at 10:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.