16

Working on Excel 2007 I am trying to populate a cell with the text HSA. However, when pressing enter, the text changes automatically to HAS.

I assume there is a kind of auto spelling correction here, but I can't find how to disable it (and, preferably, only at this cell).

  • 1
    Lol, I was just ranting about this a couple weeks ago because I was writing an email about a HSA account. – Troggy Jul 17 '11 at 1:22
  • @Troggy - yeah, exactly that... – ysap Jul 17 '11 at 1:37
24

I would remove that auto-correct word from the list like this:

Office Button > Excel Options > Proofing > Autocorrect Options and scroll down in the list until you get to "hsa", highlight it, and click delete.

You can't really disable it at a cell, but you can at least disable it for that one word you are having trouble with. You can always add it back again later.

enter image description here

  • thanks. But in the Proofing tab, the "Ignore words in UPPERCASE" is checked, so why does it insist on correcting me? – ysap Jul 17 '11 at 1:39
  • The top one is for auto-correct, the bottom one is for when you actually check the spelling (Review tab>Spelling or hitting F7). – KCotreau Jul 17 '11 at 3:53
7

File -> Options -> Proofing -> "AutoCorrect Options" button -> "AutoCorrect" tab.

It has hsa -> has correction rule. Remove it.

P.S. The path is for Office 2010, but should be the same for 2007.

  • @ysap Because those are different/independent settings. Ignore words in UPPERCASE is for spell checking and not AutoCorrect. – LazyOne Jul 17 '11 at 1:44
3

While cell is in edit mode, select text (in the cell or in the type bar), just after you typed it, and then press Enter. This doesn't make any auto correction at all, so you do not have neither to delete anything in your auto correct list nor disable auto correction. Not even have to add space, which may have unwanted results later.

  • Nice tip! The only downside is that you need to do a mouse-action for that, or, alternatively, press F2 and then Shift+Home to select all before clicking on Enter – ysap Feb 2 '16 at 21:50
1

Another quick workaround is to use a formula like this: ="HSA"

  • On my machine it corrects the string back to ="HAS" as I type it... – ysap Oct 18 '12 at 17:35
1

I was having the same problem and found a simple fix!

This person's example was for the word CNA changing to CAN.

"If you type CNA followed by a space, it is turned into CAN. Press Ctrl+Z before doing anything else to undo this change, then type on."

1

I did the following workaround as I dont want to loose the Autocorrect option.

  1. Windows Key+R -> to open the Run dialog.
  2. Type HSA.
  3. Cut the whole string.
  4. Paste it into the Excel cell.
  • Works, but somewhat cumbersome. Of course, you can cut/paste from any other source, not only W+R. – ysap Feb 7 '19 at 17:12
0

Use a single quote (') at the beginning of the cell contents, as in

'HSA

in order to use the cell contents as-is without being reinterpreted or corrected by Excel. This is also good when you type in numbers that you want to be treated as text, so that Excel doesn't autoformat them with decimals, as dates, or use right-alignment.

  • Thanks but it is the same as @JJS' suggestion. – ysap Jan 3 '15 at 2:45
-1

didn't work unteaching the spell check as has or HAS wasn't there to unfix. So I taught spell check to make HAS into HSA. that worked.

  • your answer is like a comment please Edit it and answer the question – yass Jul 16 '17 at 19:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.