6

enter image description here

In Windows 7 - as seen in the above screenshot - while opening a folder in Explorer, it seems the OS scans (indexes?) the folder as well. It therefore causes some undesirable delay.

Can anyone advise what exactly the OS is doing? What does the green progress bar mean? Is it recommended to disable that feature?

5

Your folder is "customized" to display images, movies, etc, so Windows keeps scanning the folder every time you open it to give you thumbnails, etc.

To stop Windows from re-scanning the folder each time:

  • Right click the folder, select properties.
  • Select the "Customize" tab
  • There is a drop down labelled "optimize this folder for". Select "Documents" form the drop down.
2

This usually happens on the first load of the view or a refresh. Explorer has to content with preview filters, new icons, etc etc etc. But after the first load, you are golden. I have some similar folders.

enter image description here

If you'd like to know more about how Explorer's process, I'd hit up MSDN. Especially concentrate on the interfaces.

http://msdn.microsoft.com/en-us/library/bb774328(v=VS.85).aspx

1

What is in the folder? It is not possible to disable the explorer functions. If the folder contains items that have data in them that is displayed in the columns of the details view, then that data needs to be extracted. For music, for example, the bitrate and length of the songs are extracted. For images, width, height, resolution, etc.

The best way to prevent this from taking too long is to limit the number of items in a folder to a small, reasonable number.

1
  • 1
    I have same folder, same amount of files (100-200 items) in WinXP. It never delays while inspecting the folder in WinXP. However, it takes 2-3 seconds to retrieve metadata as you said in Win 7. How come Win 7 gives worse/slower performance? – Stan Jul 17 '11 at 8:26
1

Check all 3rd party applications.

For example, something like the Carbonite (AVG) automatic backup has been found to really slow down Windows 7 explorer.

Other issues: Turn off thumbnails.
Picture and video optimization.

Also see: Windows 7 Green-Bar-of-slowness. (why do simple tasks like sorting a folder by size or name take so long?)

0

Your folder is "customized" to display images, movies, etc, so Windows keeps scanning the folder every time you open it to give you thumbnails, etc.

To stop Windows from re-scanning the folder each time:

  • Right click the folder, select properties.
  • Select the "Customize" tab
  • There is a drop down labeled "optimize this folder for". Select "Documents" form the drop down.

That is the right way to do it the answer is correct. But let me add this to it. If you wish use the drive letters instead of choosing folders one by one if you have USB external drives containing music and other things and then select properties--->Customize--->Optimize this Folder for--->then Choose (General Items) then Finally Check the Also apply This To All folders Check Box Done.....This Applies to windows 7 and 8 only I Guess.

0

I know this is a old post, but google point to this post when you are looking for a solution.

The fix for this issue is pretty simple and works with Windows 10 also, all you have to do to fix this is to open your folder options at view > Advanced settings and disable "Display file icons on thumbnails".

Finally a solution

That's it, no more folder scanning, it will scan folders if you have image files, videos, music, etc. Other than that it will act normal, if you know some file has a thumbnail and explorer is not showing it, just hit F5.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.