3

This is the error:

[Window Title]
C:\Users\Sergio\Desktop\Things\Setup.exe

[Content]
The version of this file is not compatible with the version of Windows you're 
running. Check your computer's system information to see whether you need an 
x86 (32-bit) or x64 (64-bit) version of the program, and then contact the 
software publisher.

[OK]

I'm running Windows 7 (64bit) Ultimate and have installed this service pack before (2 days ago) on another machine with similar specs and the same exact OS software.

I've tried mounting the .ISO file to a virtual drive and installing from there and I get that error.

I've tried mounting the .ISO and copy pasting the files to a local folder on my drive and then running the setup.exe application, and I get that error.

I don't know how to proceed but can provide any additional information you require from me. What can I do to fix this?


Edit

If I right click Setup.exe and Run As Administrator, I get the following error:

[Window Title]
C:\Users\Sergio\Desktop\Things\Setup.exe

[Content]
Windows cannot find 'C:\Users\Sergio\Desktop\Things\Setup.exe'. Make sure you 
typed the name correctly, and then try again.

[OK]

I've already tried re downloading the ISO from the site, but a quick check of the bytes of the file assures me that the ISO on my drive is 100% correctly downloaded. I get the same amount of bytes in size from the downloading ISO (as Opera reports).

1

Have you verified the ISO checksum also?

This link contains the ISO's checksum value and also explains how you can calculate it from the ISO file you downloaded: Verify the ISO checksum for Visual Studio 2010 Service Pack 1 before installing

1

The file may be in a blocked state. This is typical of any executable that's downloaded to Windows XP+. If you right click on the file, select Properties, then click Unblock to unblock the file.

Does that fix the issue? If that's the case, you can disable this SECURITY feature, if you choose...

http://www.petri.co.il/unblock-files-windows-vista.htm

4
  • 1
    I can't find this Unblock property you mention. Screenshot? – Only Bolivian Here Jul 19 '11 at 2:19
  • Screenshot is on the link I've posted. If you don't see it, then it's not blocked. :D Must be a different issue, but it sounds a lot like the one I've described above. – iOnline247 Jul 19 '11 at 2:20
  • @Sergio: Generally, this isn't going to be a problem for an Iso. Are you coping all the files out of ISO to your harddrive or something? I'm trying to figure out why you would run setup from inside your user directory? – surfasb Jul 19 '11 at 7:19
  • Am I the only one that has seen an .iso being blocked in this fashion? I've ran into this on numerous occasions. The next logical step would be to extract the contents of that .iso the filesystem and try to install. Are you successful in doing that? Daemon Tools can assist in mounting an .iso. – iOnline247 Jul 20 '11 at 4:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.