10

I use putty to login to my RHEL 5.3 server. I'm prompted to enter my login as "login as" and I enter my login Id. As soon as I press Enter, I see a "Access Denied" message following which I'm prompted with password. I successfully enter password and I'm through -- no problems.

I tried the same with putty 0.60 (as opposed to above putty 0.61), but in this version, I don't get any "access denied" error. What should I make of this? Is putty 0.61 version buggy?

P.S.: If I login using ssh.exe (from cygwin), then I'm fine -- I don't get any "access denied" errors.

14

PuTTY tries several authentication methods in a row, which might cause these messages:

  • GSSAPI (only if your system and the server have it enabled)
  • Public key (only if you have a key loaded)
  • Password

After receiving the "Access denied" message, hold Ctrl and right-click on the PuTTY window, then select Event log. At the bottom you will see what exactly caused the failure.


Update: PuTTY 0.62 fixed the bug where failing GSSAPI authentication caused this error message.

6
  • aha! that was a a cool explanation. – anjanbacchu Jul 19 '11 at 14:03
  • I got the same error message and confirmed it was being caused by GSSAPI authentication. I disabled GSSAPIAuthentication in sshd_config. Was that the correct thing to do? – Barry Brown Aug 29 '11 at 6:49
  • @Barry: My opinion on that varies. Was it a personal computer? Was it a standalone server? GSSAPI is unneeded for those and it's okay to disable it. Was it one server out of a large network of servers? GSSAPI is not needed either, and it's still okay to disable it, but it can make logins much more convenient if set up properly. – user1686 Aug 29 '11 at 8:27
  • It's a standalone server. Thanks for the info. – Barry Brown Aug 30 '11 at 4:48
  • 2
    @BarryBrown, you disabled GSSAPIAuthentication in sshd_config, which is ok, but I think the better option is to tell PuTTY not to try using it. You can do that via PuTTY options Connection > SSH > Auth > GSSAPI. Uncheck the 'Attempt GSSAPI authentication' checkbox. – Kem Mason Sep 22 '11 at 18:27
1

You can just edit configure file of putty in directory /home/Lifeix/.putty/sessions, change AuthGSSAPI=0 to AuthGSSAPI=1

1

This has been fixed in version .62 which is currently in pre-release stage. I deleted my old putty app exe file, then downloaded the .62 version from their website. Ran it and now the Access Denied error is gone without having to change GSSAPI settings on either the server nor in putty.

1

In putty configuration go to Connection, SSH and then under Protocol options change Preferred SSH protocol version from 2 to 2 only and then under SSH Auth GSSAPI uncheck the Attempt GSSAPI authentication (SSH-2 only) check box and save.

Not the answer you're looking for? Browse other questions tagged or ask your own question.