2

I have the excellent ido mode set up on Emacs 23.1 (Windows 7).

If I'm in dired and decide to make a new file, I do C-x C-f, which is bound to ido-find-file.

(I should really do C-x C-f C-f to get normal find-file, but I always forget.)

Halfway typing the new file name, ido starts looking for an old file of that name ("Searching for ...."). This will be a pointless quest.

Since I also edit a lot of files over the network and ido seems to be searching UNC paths and the like, this effectively locks Emacs up for a while, so is pretty annoying.

C-g doesn't break out of it and neither does ESC. Does anyone know if there's another way to stop ido?

4

I have the following in my .emacs:

 (add-hook 'ido-setup-hook 'shab-ido-config)

 (defun shab-ido-config()

 ;; ... other ido-config here ...

 ;; disable auto searching for files unless called explicitly with C-c C-s
 (setq ido-auto-merge-delay-time 99999)
 (define-key ido-file-dir-completion-map (kbd "C-c C-s")
   (lambda()
     (interactive)
     (ido-initiate-auto-merge (current-buffer)))))

Which effectively disables the auto-search unless explicitly requested (with C-c C-s). There's still the issue of your new filename matching an existing file in hte current dir, which opens that file by default (which is annoying).

The workaround I've found to that problem is to use C-f from ido to drop back into the non-ido find-file function.

  • Thanks for that suggestion. I'm using it now and I suspect it is as close to what I want as is possible, so I'm marking this as the answer. – Peter Reavy Aug 15 '11 at 12:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.