26

Just got a new Windows 7 PC (64-bit) with an Intel DH67CL motherboard. It's been working fine but I decided I wanted to try to get into the BIOS. Unfortunately I can't do it because my USB keyboard isn't powered up on boot.

I've tried 3 different keyboards and almost all of the USB ports with no luck.

Any idea how to get into the BIOS?

31

Well as soon as I got my question typed in I figured it out, at least for this Intel motherboard.

I found another computer with the same motherboard and browsed the BIOS settings. Under Boot/Fast Boot/USB Optimization I found this descriptive text (nowhere in the manual by the way):

"If Enabled, USB devices (keyboards and drives) will not be available until after OS boot, but BIOS will boot faster. If Disabled, USB devices will be available before OS boot, but BIOS will boot slower. This question does not affect USB capabilities after OS boot. This question cannot be enabled while a User Password or Hard Drive Password is installed. In order to disable Fast Boot without entering BIOS Setup: Power down the system, then hold down the power button until the system beeps."

I tried it, heard 3 beeps, then it booted to a screen saying that the Fast-boot trigger had been detected, would I like to enable fast-boot on the next boot. No!! Noticed that my keyboard light was on and hit 'N'. It rebooted again and I was able to hit F2 to get into the BIOS.

3
  • 2
    My question is why would anyone want this enabled in the first place. Seems to be a security feature to keep users out of the bios. Thanks for the info, screenshot of the bios page and description would be nice – Moab Jul 20 '11 at 23:36
  • 2
    Maybe if you're really concerned with bootup speed, but definitely not a good default setting. – jacobsee Jul 20 '11 at 23:47
  • Sometimes my Nuc doesn't produce a beep, so I count 3 seconds while pressing. – Rael Gugelmin Cunha Apr 18 '18 at 19:12
4

Don't forget the oldest trick in the book:

Take out the lithium battery for a few minutes, and then turn on the system.

1
  • Doesn work with laptops and tablets (cause you may lose warranty). – TomeeNS Jun 3 '16 at 13:42
0

For me, the computer can use USB keyboards in the BIOS and the default BIOS config does that - however a custom configuration caused the keyboard to be ignored. If you think this is the issue - you can reset all your BIOS settings by reverting to their default values using the CLR_CMOS button/jumper. See: https://superuser.com/a/1095663/100736 .

WARNING: Don't do that if you do not know what this means or afraid to lose custom settings!

2
  • That shoukd RESET all settings. Now how is OP going to enter correct (non-default) values without a normal PS2 style keyboard? – Hennes Nov 3 '20 at 13:28
  • Good point. I have edited my answer. – Udi Nov 3 '20 at 13:36
-4

1- restart your computer
2- press Delete button on keyboard so the CMOS setup utility screen will show up
3-chosse the third option (integrated peripherals)
4-another screen will show up then choose (USB keyboard support:turn it to enabled)
5- now press F10 to save it

see this link: http://www.youtube.com/watch?v=5qWtkO1yO4Y

3
  • 7
    How does the OP press the Delete button without a working keyboard? – Tog Nov 5 '13 at 11:04
  • 3
    @user269585 - If you are going to answer a question that already has an accepted answer its always good to make sure your answer is even possible to do. The user had disabled USB devices until the OS booted thus your suggestion is invalid. – Ramhound Nov 5 '13 at 13:07
  • I know it does not seem to answer the question but that is exactly what has helped me solve it. My keyboard was working to get into the BOOT menu or CMOS setup but stopped working in the BOOT menu so that I couldn't select anything. – lukaskrieger Nov 10 '16 at 10:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.