29

I updated to OS X Lion today, and I don't seem to have a copy of gcc any more. Did this happen to anyone else? Does anyone know why this would happen?

1
  • Didn't know there was, or was supposed to be, an Xcode installer apart from the app store. Thanks.
    – user104773
    Nov 9, 2011 at 20:18

7 Answers 7

13

I was mighty pissed when I found out that the OS X Lion upgrade wiped out my entire development tool-chain. However, with help from a friend, I discovered that the tool-chain had instead been moved into the /Developer/usr/bin/ folder on disk. For my immediate need, I only had to make make, gcc and g++ available on path, so I created symlinks to /Developer/usr/bin/gnumake, /Developer/usr/bin/gcc-4.2, and /Developer/usr/bin/g++-4.2 inside the /usr/bin/ folder. However, I imagine the correct approach would be re-install XCode to fix the issue.

44

Just installed Xcode 4.3 on Lion from the app store, had the same issue with gcc, etc not installed. Fumbled around until I did the following:

in Xcode: Preferences --> Downloads With "Components" selected, you will see a list of downloadable components.

Look for Command Line Tools, and click on install. You will be prompted for your Apple Developer userid and password. After successfully authenticating, the command line tools component downloads and installs a bunch of goodness, including gcc.

3
  • 3
    I can't imagine how long it would have taken me to find this Mar 1, 2012 at 1:13
  • 1
    This answer along with export PATH=${PATH}:/Developer/usr/bin done it for me Apr 12, 2012 at 7:34
  • I didn't need to export the path. After install it just worked. Thanks jbm hack
    – sdjuan
    Aug 7, 2012 at 0:36
7

Download the new Xcode from the App Store and run Install XCode. It's now free, not $4.99.

11
  • 8
    This is over 3 GB. Does Apple really hate developers this much? Jul 21, 2011 at 6:17
  • Yes. Have fun updating too.
    – Vervious
    Jul 21, 2011 at 6:30
  • @Zach Well the Dev tools have always been a bit huge, but wouldn't you have to install a new version of Xcode anyway when upgrading the system?
    – slhck
    Jul 21, 2011 at 6:35
  • 1
    You can still get Xcode for free if you register (again for free) with Apple Developer Connection (developer.apple.com).
    – Scott
    Jul 21, 2011 at 7:04
  • 4
    @Nerian: Download and Install Xcode from AppStore, run "Install Xcode.app" (I missed this step, don't just assume it's installed after installing from the AppStore), then gcc and the other build tools suddenly work. Whoo
    – timoxley
    Jul 22, 2011 at 12:10
6

You can just put /Developer/usr/bin in your $PATH and everything is fine:

export PATH=${PATH}:/Developer/usr/bin
5

I followed these steps and was able to get GCC working again.

  1. Open the App Store.
  2. Search for "XCode".
  3. Search the whole page for any kind of “Buy” or “Download” or “Install” button.
  4. Ha ha. There isn’t one. Click on the button that says “Free”. It will turn into a button that says “Download”.
  5. Click that.
  6. Wait for it to download and install. Now the App Store will claim that you have installed Xcode. Congratulations!
  7. But you haven’t.
  8. Open Finder and go to your Applications.
  9. Find the “Install Xcode” application. Not joking.
  10. Run it.
2
  • 2
    If you have Xcode allready installed, run sudo /Developer/Library/uninstall-devtools --mode=all to uninstall and then continue from step 8.
    – bouke
    Nov 25, 2011 at 1:53
  • I uninstalled Xcode & attempted to reinstall, but there was no “Install Xcode” step… however I still don’t have gcc-4.2 in my command line…
    – Alan H.
    Mar 6, 2012 at 17:14
0

I had this issue too, where even after I install XCode4, there was no gcc in my path. But it turns out my install was just borked. I reran the XCode installer and now /usr/bin/gcc is a symlink to /usr/llvm-gcc-4.2/bin/llvm-gcc-4.2 as it should be.

edit: secoif's comment was correct. Just reinstall XCode.

1
  • Linking to gcc that way doesn't seem to work correctly. See gist.github.com/1096750 for me trying to do that to link to gcc/make for use with OSX brew. Download and install from the AppStore as per my other comment.
    – timoxley
    Jul 22, 2011 at 12:10
0

New installations of Xcode (versions 4.2 and up) through the App Store do not ship with gcc-4.2. You can download and install Xcode 4.1 through the Apple Developer Central. Free registration required.

Not the answer you're looking for? Browse other questions tagged or ask your own question.