I'm trying to fix a computer running XP for a friend, and it is being a pain. It is on the same wifi as this Mac I'm using to type this.

It says it is connected and the signal strength is excellant. It is connecting through Windows, no 3rd party software.

If I use Chrome or IE and get to the Connections tab of the internet settings, underneath LAN settings, Use a proxy server was checked, not sure why, but I unchecked it and checked automatically detect settings, and restarted, but to no avail.

ipconfig yields:

Sub Mask:
Default Gate:

ipconfig /release zeros out, as expected

ipconfig /renew says:

An error occurred while renewing interface Wireless Network Connection : 
unable to contact your DHCP server. Request has timed out. 
No operation can be performed on Local Area Connection 
while it has its media disconnected.

I tried using winsockfix.exe, and netsh, with restarts, but to no avail.

Network Connections lists:

Wireless Network Connection (Connected, firewalled)
Local Area Connection (Network cable unplugged)
1394 Connection (Disabled, firewalled)

Edit: Also, when Chrome starts up it says "Resolving Proxy", which I thought I had disabled...

Edit 2: It works just fine on a wired ethernet connection.

Edit 3: I tried throwing in static info, but no luck.

  • 1
    What happens if you check "No proxy"? – Joe Internet Jul 22 '11 at 0:22
  • @Joe: I don't see that option anywhere. Am I blind and missing it? – Josh Jul 22 '11 at 0:24
  • Sorry, wrong browser... if you uncheck "Autodetect settings" in IE, and there is no proxy, does it make a difference? If not, you could try deleting the lan (or whichever) connection under Network Connections, and re-running the network wizard. – Joe Internet Jul 22 '11 at 0:32
  • @Joe: No dice, unfortunately. – Josh Jul 22 '11 at 0:44
  • @Joe: Also, it works fine plugged into ethernet it seems. – Josh Jul 22 '11 at 0:46

I've experienced this problem many times at client sites (and once at home) where the wireless doesn't work despite showing a "connected" state, but the wired ethernet does work. Try these steps (if they don't work, then you may need to replace the wireless router; hopefully it's still under warranty if that's the case):

  • Power cycle the wireless router (un-plug it for 10 seconds), then check its public IP settings (to make sure it's getting a public IP address, mask, and gateway that are all working correctly)

  • Upgrade the wireless router's firmware (this sometimes resolves connectivity issues)

  • Try using a different channel (this will cause your wireless router and NICs to use a different frequency -- if your neighbours are utilizing a lot of wireless bandwidth, then using a different frequency should yield better performance for you because you won't then have to compete with them for bandwidth); you can use Network Stumbler (free and intended to be open source) to see which frequencies are not in use: http://www.stumbler.net/

  • Try using a different wireless network name (if one of your neighbours is using the same name, you could be experiencing conflicts)

  • Try re-entering your passphrase (on the wireless router's administrative interface and on your local computer for the wireless NIC)

  • Make sure the signal is strong (a weak signal can be caused by interference from a number of things, including microwave ovens, cellular phones, wiring in walls, etc.); if it's weak, then this could be causing your problem (try moving closer to the wireless router -- if this resolves the problem then the solution is to physically move the computer and/or the wireless router)

If all that fails, then your last option may have to be to replace the wireless router. Hopefully that's not the case for you.

  • Unfortunately, this is just a friend of the girlfriend's computer. It suddenly stopped working on her home internet, and won't work on her work internet. I have it at my house now, inches from the third router, it is connected with full bars, but will not get internet. It's like it has a proxy, but there are none set under the internet options. I just did a full scan w/ MSSE and there are no viruses etc forcing proxy... – Josh Jul 22 '11 at 1:26
  • 1
    Oh, in that case, try updating the wireless NIC drivers (and don't bother with Windows Updates for this because that tends to get you either a watered-down version {possibly to make it easier to get Microsoft's approval for inclusion} or is not the newest version -- get the newest version from the manufacturer's web site). – Randolf Richardson Jul 22 '11 at 1:29
  • 1
    @Randolf Richardson I was too busy (actually installing SQL Server on the other side of the US) to spend much time on this, but my first thought was dying router. I have seen this behavior too. – KCotreau Jul 22 '11 at 1:41
  • 1
    @Randolf: It did instal 3rd party junk, but the new drivers did it :) Weird. – Josh Jul 22 '11 at 1:50
  • @Josh: Thanks for sharing an update (+1) that the newest version of the driver solved the problem. – Randolf Richardson Jul 22 '11 at 2:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.