I'm actively using VirtualBox on a Windows 7 host to run XP and a few Linux distributions, mainly for testing. My mouse is a Logitech optical with extra buttons. Now how do I get the back and forward buttons to work in my Guests?
I tried installing the drivers supplied from Logitech on the Guest, but that didn't help (Couldn't find the correct drivers to begin with).
Also tried setting USB support for my mouse (VirtualBox VM settings), but then my mouse just stops working completely util I reboot.

The only solution I found so far is to run the Guest, and then start an RDP session, but that slows things down quite a bit.

Is this even possible at all?


Well, after some recent updates of VirtualBox, it seems like it's working now, without installing extra drivers for the mouse. Awesome.

2 Answers 2


I don't think this is possible in VirtualBox. Regardless of what your mouse actually is, VirtualBox emulates a standard 3-button wheel mouse in the guest.

However, maybe it's possible using VBox's "expose USB device to guest" feature (whatever it's called). You said you tried it and the mouse stopped working for the host, which is expected. However, you can try connecting two mice to the host computer, and then exposing the one you want to the guest. Then you can still use the second mouse to control the host.


Couldn't find the correct drivers? If you have a Logitech mouse, the Logitech SetPoint drivers should be all that you need. The first thing I do when i set up a VirturalBox instance is install SetPoint within the VM. From what I recall, all the extra buttons for my Logitech MX Revolution within my last VM (Windows 7 RC) worked fine.

And for extra buttons within Linux, I can't help you at all.

  • well, i installed the SetPoint drivers, but no luck.. still doesn't recognize my extra mouse buttons. If I enable usb support in virtualbox, my mouse stops working completely, both on the guest and host! I think I'll just update my XP guest to a 7 soon.. that might fix the problems. Thanks anyway.
    – RoelF
    Sep 9, 2009 at 11:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .