I have PuTTY installed on Vista. When I set it to Telnet and put in a host name of SMTP2Go.com and port of 25 the window opens for a second not showing any text then closes. I also tried ports 2525, 587, and 8025, which SMTP2Go says also work with the same result. I use Telnet from the command prompt (which I had to enable from the control panel) to open smtp2go.com with port 25 and it works. I also can use both PuTTY and the other Telnet to connect to outgoing.verizon.net. I am using Frontier for my ISP and it says on their site that port 25 is blocked, and other people have confirmed this, so I find it strange that I can access SMTP2Go on port 25 using Microsoft Telnet. Could SMTP2Go determine what client I'm using and block certain ones?

Also in Microsoft Telnet there aren't line breaks between my commands and the server's response with Verizon, but with PuTTY there are.

2 Answers 2


Just select "Raw" in the "Connection type" field and it will work OK.

From PuTTY's documentation:

A lot of Internet protocols are composed of commands and responses in plain text. For example, SMTP (the protocol used to transfer e-mail), NNTP (the protocol used to transfer Usenet news), and HTTP (the protocol used to serve Web pages) all consist of commands in readable plain text.

Sometimes it can be useful to connect directly to one of these services and speak the protocol ‘by hand’, by typing protocol commands and watching the responses. On Unix machines, you can do this using the system's telnet command to connect to the right port number. For example, telnet mailserver.example.com 25 might enable you to talk directly to the SMTP service running on a mail server.

Although the Unix telnet program provides this functionality, the protocol being used is not really Telnet. Really there is no actual protocol at all; the bytes sent down the connection are exactly the ones you type, and the bytes shown on the screen are exactly the ones sent by the server. Unix telnet will attempt to detect or guess whether the service it is talking to is a real Telnet service or not; PuTTY prefers to be told for certain.

In order to make a debugging connection to a service of this type, you simply select the fourth protocol name, ‘Raw’, from the ‘Protocol’ buttons in the ‘Session’ configuration panel.


That is because there is no SMTP server for "SMTP2Go.com", so Putty is just closing an impossible/non-existent connection. Their SMTP server is actually "mail.treshna.com". Check out this NSLOOKUP for them.

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

Default Server:  google-public-dns-a.google.com

> set q=mx
> SMTP2Go.com
Server:  google-public-dns-a.google.com

Non-authoritative answer:
SMTP2Go.com     MX preference = 5, mail exchanger = mail.treshna.com

I was able to use Putty to telnet on port 25 to mail.treshna.com. Also, when I telnet on port 25 to SMTP2Go.com at a command line, as soon as I enter EHLO, it give me this error: "554 SMTP synchronization error" and "Connection to host lost." The server mail.treshna.com does respond to EHLO at a command line telnet on port 25.

  • 1
    This is not correct. I can open a session from Putty to smtp2go.com at port 2525. You just need to select "Raw" protocol instead of "Telnet".
    – Grodriguez
    May 17, 2012 at 19:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .