3

I'm using Mac OS 10.6.7 on a low memory MacBook, so I would like to kill the Dashboard and not have it running at login. Tried this

    defaults write com.apple.dashboard mcx-disabled -boolean YES 

...but couldn't make it work.

6
  • 2
    That last sentence provides absolutely no information, since you fail to mention which commands didn't work for you.
    – Daniel Beck
    Jul 24 '11 at 19:01
  • Thanks for the comment Daniel, I've added the command now.
    – villares
    Jul 24 '11 at 19:14
  • Have you logged out and back in since entering the command?
    – Daniel Beck
    Jul 24 '11 at 19:18
  • @DanielBeck Or reopened Dock.
    – Lri
    Jul 24 '11 at 19:21
  • Yes, I've logged out and back. Didn't work :(
    – villares
    Jul 24 '11 at 19:27
3

Enter the following Terminal command:

defaults write com.apple.dashboard mcx-disabled -bool true && killall Dock

It worked for me.

5
  • Thanks for the reply, something else is going on. It didn't work for me.
    – villares
    Sep 16 '11 at 12:12
  • @villares To clarify, Dashboard is still running although you set this command?
    – Daniel Beck
    Sep 16 '11 at 12:41
  • Still works with 10.8.
    – Max Howell
    Jul 30 '12 at 22:44
  • I typed sudo in front of it, just in case.
    – bobobobo
    Sep 7 '12 at 16:38
  • @bobobobo defaults manages user defaults, or, in other words, preferences. Some of them are hidden, but they're almost exclusively user account specific.
    – Daniel Beck
    Sep 7 '12 at 18:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.