Sometimes this dialog box will pop up (see screenshot below). Every time it appears I select "Keep the current color scheme, and don't show this message again". Windows then reminds me again -- either the next day or after reboot, or sometimes another 5 minutes later.

Do you want to change the color scheme to improve performance?

Do you want to change the color scheme to improve performance?

Windows has detected your computer's performance is slow. This could be because there are not enough resources to run the Windows Aero color scheme. To improve performance, try changing the color scheme to Windows 7 Basic. Any change you make will be in effect until the next time you log on to Windows

  • Change the color scheme to Windows 7 Basic
  • Keep the current color scheme, but ask me again if my computer continues to perform slowly
  • Keep the current color scheme, and don't show this message again

Is there some reason why Windows is ignoring/forgetting my attempts to suppress the dialog? I'd love to never ever see it again, it's annoying, and it alt-tabs me out of fullscreen applications.

If it matters, I'm running Windows 7 x64 Professional. I believe the dialog appears because I'm forcing Vsync and Triple Buffering for DirectX applications.

  • 1
    Are you by any chance using NXclient from NoMachine? If yes, then just disable DirectDraw in session configuration. – dtoubelis Nov 23 '11 at 4:11
  • Nope @dtoubelis, in my case it appeared when I was running Just Cause 2. Good advice for anyone using NXClient though =) – William Lawn Stewart Nov 30 '11 at 10:57
  • 1
    @FakeName give a try, right click My Computer on the desktop, select Properties>Advanced System Settings. Under the "Advanced" tab, click the Settings radio button under "Performance" and either select a custom scheme, or, Click the button for Adjust for best appearance or Adjust for best performance and click "Apply". – avirk Nov 3 '12 at 12:38
  • bitsum.com/forum/index.php?topic=1128.0 check out that link and try out the .bat files to run the games. – avirk Nov 3 '12 at 14:49
  • 1
    Have you tried switching Vsync off? See this article. – harrymc Nov 5 '12 at 8:51
up vote 72 down vote accepted

Assuming you realize this message is informing you your system is low on resources and is asking you to disable Aero so it can keep performing at optimum speed,

  1. Go to the Start Menu and type Action Center on the Search box
  2. Start it (it should be the top entry, under the "Control Panel" group)
  3. On the left sidebar, click Change Action Center settings
  4. Untick the Windows Troubleshooting checkbox, under "Maintenance Messages".
  5. Click the Ok button and you are done.

Here is a screenshot of the setting screen:

Alternatively:

  • You can try and keep this setting just as it is and switch to Basic desktop mode before launching the applications that usually fire up this Action Center notification. Or,
  • You can right click the icons you use to fire up these full screen applications, clicking properties and under the Compatibility tab tick Disable desktop composition. This will disable the Desktop Window Manager Session Manager service during execution of this application which will increase system and video memory and avoid some application incompatibilities. A likely cause for your Action Center message if you have enough system and video memory but are stuill getting this message with certain games or full screen applications.
  • 3
    Worth being mentioned just bad hardware device driver messages that will no longer be displayed. Ã rare occurrence if you don't make changes to your hardware or always download drivers from reliable sources. – A Dwarf Jul 25 '11 at 0:13
  • 64
    @will hmm, I am not sure this answer is correct. I do not have "Windows Troubleshooting" checked and I keep getting nagged with this dialog. – Jeff Atwood Nov 21 '11 at 23:42
  • 2
    Answer for french windows 7 version because it is not very well translated: Panneau de configuration/Système et sécurité/Centre de maintenance/Modifier les paramètres du Centre de maintenance(Left menu). – Doomsday Dec 18 '11 at 20:36
  • 14
    This doesn't work. I have it unchecked. – user2867288 Dec 6 '15 at 4:22
  • 8
    I really like this answer except for the fact that it doesn't work. – Jake Oct 21 '16 at 11:30
up vote 27 down vote
+250

I'm constantly in a similar situation even though I never get that exact same message, and have done a bit of testing around.

To my understanding, the core resource that is under stress here, is the GPU memory. But this doesn't necessarily indicate that you're running out of this resource in general. It might just mean the Desktop Window Manager has detected that you're running so low that one specific feature of this service could be disabled to free up more memory.

To test this, I started opening up GPU memory intensive applications:

enter image description here

This is somewhat above average use on my triple-screen setup with a few key players running (Visual Studio 2012 (hardware acceleration enabled), PhpStorm, Aptana Studio, Chrome, Firefox, IE, ...). So, yeah, if you only have a 1 GB card and this would be your usual usage scenario, you'd already have a problem.

I had to push a bit further and start a couple more Visual Studio instances...

enter image description here
enter image description here

...until it was nearing the 1.5 GB mark and...

enter image description here

SNAP! This caused Windows to kill desktop compositing completely (and free up some precious resources).

Now, when I'm already at a critical level, and I start an application that uses excessive amounts of GPU memory in fullscreen, I can even go beyond this critical limit. Here's the result after running Black Mesa for a while on 2560x1440 at max details:

enter image description here

So, two things can be deducted from this. While going over the 75% mark on the desktop can force Windows to disable desktop composition, when reaching the same limit in a fullscreen application (and, optionally exiting that application) desktop composition is not disabled.
The second thing is, while you're in your game, you can get the idea "Hey, I have enough resources to run this game, why don't I have enough resources for the desktop?". The reason is, both require memory at the same time.

Windows might only be able to tell you about the memory situation after you exited the game. So, when I start another Visual Studio after exiting Black Mesa... enter image description here

So, what can we do about this?

Get more GPU memory

Sweet and simple.

Disable Desktop Composition (per process)

As was already suggested, you can disable desktop composition for a single executable. This has the effect that desktop composition is temporarily disabled while the executable is being executed. This drastically reduced the overall memory consumption while the application is executed in my tests:
enter image description here

The bounty notice mentions that this is undesirable, as this is potentially a lot of work.

Disable Desktop Composition (globally)

I wouldn't consider this a solution as desktop composition is usually desired. But this is where to disable it:

enter image description here

I just want to get rid of the annoying message!

Just because you remove the warning "Your battery is almost empty! You can only talk for 10 more minutes!" does not mean you can talk for longer than 10 minutes. In fact, your phone will most likely simply shut off and that's it. Now how's that for an improvement?

I never assumed the message can be turned off and I don't see how that could be considered a benefit.

You might think you know better, but you don't. If the system is telling you it's running out of resources, it is.

But it isn't! I know!

Ok, let's assume Windows is just not smart enough to detect the special situation you're in and the warning message is simply an annoying inconvenience. What now?

The thing is, me personally, I'm also affected by this and it's annoying the hell out of me. Because I don't even get that warning message. Windows simply switches my color profile and that's it. And I like that actually.

When it happens I usually quickly run a script that calls

net stop uxsms & net start uxsms

Here is the full script. It will pop open a UAC prompt and restart the service so it can be triggered from anywhere. I have it pinned to the start menu.

@if (1==1) @if(1==0) @ELSE
@echo off&SETLOCAL ENABLEEXTENSIONS
>nul 2>&1 "%SYSTEMROOT%\system32\cacls.exe" "%SYSTEMROOT%\system32\config\system"||(
    cscript //E:JScript //nologo "%~f0"
    @goto :EOF
)
NET STOP uxsms
NET START uxsms
@goto :EOF
@end @ELSE
ShA=new ActiveXObject("Shell.Application")
ShA.ShellExecute("cmd.exe","/c \""+WScript.ScriptFullName+"\"","","runas",5);
@end

This restarts the Desktop Window Manager and brings me back to my composited desktop (and it frees up lots of resources in the process, yay).

Knowing this, you can also construct yourself a special gaming environment where you stop the service before starting the game to combat this whole behavior. However, this will cause identical behavior to disabling desktop composition for a single executable through the file properties.

  • 21
    The issue (for me, at least), is that while I may be running low on memory, everything is still performing fine, and if I click "Don't change anything" the game AND dwm.exe perform perfectly fine. So No, I don't want a tweak that reduces my memory udace, I want to make JUTS THE DIALOG go away. – Fake Name Nov 4 '12 at 9:26
  • 6
    If I run into a situation in the future where I actually do need the additional video memory that's used by the desktop composition engine, I'll fix that then. However, at this point, I don't need that memory back. – Fake Name Nov 4 '12 at 9:27
  • 12
    I mean, the dialog has exactly what I want as one of the button options, but that button doesn't work. Keep the current color scheme, and don't show this message again. – Fake Name Nov 4 '12 at 9:29
  • 1
    All great points but... I have a system with two ATI Radeon HD 5450 cards and the only thing I'm running is iTunes & Chrome - and I'm getting this. That makes no sense. – David Thielen Jul 7 '13 at 15:26
  • 25
    "I never assumed the message can be turned off and I don't see how that could be considered a benefit." - Because this message pops up often when playing video games, pulling me out of the game (which sometimes isn't paused) just to disable this message once again. I don't care that my system is using all its GPU ram (in fact, that's a good thing). I don't care if Windows Aero runs slow while I'm in my game, as long as the game continues to run fine - which it always does. I just want this message to not disrupt my gaming. – BlueRaja - Danny Pflughoeft Nov 14 '13 at 21:21

I have been getting this damn message nagging me all the time as well (for long time now) on Windows 7 PC's, mainly when remotely accessing them by VNC (any flavor), but wanting to keep Aero and desktop composition turned on (surely not using VNC mirror driver else no Aero for sure).

The switch to basic theme, even if temporarily, would for example break gui's for some old apps (like the ones getting DPI virtualization, only available with Aero + desktop composition), that was one of the reasons I wanted to keep Aero and desktop composition turned on, as default, but just stop the damn message, moreover the system was actually running fine, as many users confirm on comments in this page, then the problem was just the message!

Unticking the "Windows Troubleshooting" checkbox under "Maintenance Messages" is just no solution, as many also confirm on comments here, it doesn't work, and disabling desktop composition is... well... like telling to turn off your car motor because it doesn't work properly... i.e. not a solution...

After being nagged with this message for long time I decided I really had to stop this, then I debugged dwm.exe and finally found how to kill the message permanently... if you want to do the same and you have Windows 7 SP1 x64 (it is probably different for x86) just patch your dwm.exe like I did:

Warning: Only do this if you know what you are doing, else you may break your system !!!

for Windows 7 SP1 x64:

(original file md5: f162d5f5e845b9dc352dd1bad8cef1bc)
open file on an hex editor and search for this pattern:
FF15D2A5000085C079
replace it by:
9090909090909090EB
(patched file md5: 2ab05d7454dcd8ef20a7f99b3390973d)

for Windows 7 SP1 x64 + KB3125574 Convenience Rollup:

(original file md5: c206c9dbfc34afd367dd150d979a5185)
open file on an hex editor and search for this pattern:
FF1562B1000085C079
replace it by:
9090909090909090EB
(patched file md5: 8243c03dad2b9aaaddabe65e4869e2ae)

(the patch just removes the call to the TaskDialogIndirect api, responsible to show the message window and forces a jmp, that would originally be taken if the call return is success... the jmp must be taken as code is apparently also done to just switch to basic theme if it can't show the message)

Note that to be able to do changes/rename/replace your dwm.exe file you need to stop "Desktop Window Manager Session Manager" service (on services.msc), so that it stops running, and take file ownership and adjust permissions... as the file is owned by TrustedInstaller by default...

Also note that in my analysis to dwm.exe I found that there are actually two of these messages (similar but not the same):

  • one is the one shown at the top question screenshot, this one shows up when dwm.exe is using some cpu resources... something like 30% may be enough to trigger it (and VNC makes that happen), my patch removes this message.
  • there is another similar message, but with slightly different text, that shows up when dwm.exe is using too much GPU memory, that one is not the one shown on the question screenshot and my patch will not remove that message.
  • 6
    Congratulations on being the first person in 5 years to actually bother to answer the question without dodging the question with a pedantic "You shouldn't be ignoring this Totally Actionable and Not Superfluous warning." Sadly, patching executables is too much of a risk in my view, though I can confirm that my MD5 matches yours. – Lilienthal Apr 5 '17 at 16:00
  • 2
    Thank you Lilienthal. I understand what you mean, I usually also dislike patching, however IMO there is no much risk on this case as the patch is really very simple, it basically just removes the api call that creates the message, and seems really the only permanent way to fix it... – nars Apr 6 '17 at 22:37
  • You literaly hacked windows desktop manager to fix one of its annoying behavior.. seems fair – Drax Jun 17 '17 at 23:59
  • 1
    Thank you!!! I was getting this message every time I played Fallout 4 on my gaming PC. The game runs flawlessly but this stupid message always popped up. You are my god. – user2867288 Jul 5 '17 at 3:47
  • My checksum matched and I made the same edit with the same result but unfortunately this same message continues to pop up. Not sure that this fix is still working. Have an upvote for finding this solution and getting my hopes up, though. – S.C. Jul 12 '17 at 2:56

You are running out of GPU memory. This may be :

  1. A bug in a graphical-intensive program that you are using (such as a game)
  2. A bug in the video driver,
  3. A resource-starved computer.

As you are running Windows 7 x64, the third possibility doesn't probably apply.

For the second possibility, you could update your video driver to the latest version as found on the manufacturer's website.

For the first possibility, if this is always happening when running the same program, then it might have compatibility problems with the Aero theme. To disable Aero while running that application, modify the Properties of its executable to "Disable desktop composition" :

enter image description here

  • Sidenote: You can only disable desktop composition for x86 executables, and some specifically compiled x64 executables. – Fake Name Dec 22 '16 at 3:19
  • 1
    None of your proposals are true. The problem is NOT that I'm running low (or out of) GPU memory, but that Win7 has a bug in that it uses archaic percentages for what it thinks is low GPU memory. (67% for warning, and, it seems, 75% for mandatory toggle). Problem is, if you have 4GB memory, that 67% message kicks in with over 1.2GB free. It's to swap/paging file advice from years ago vs. now. Recommendation used to be to size swap/page @ 2X memory size. When I had 512MB memory, I stopped using swap (w/128GB memory, I still don't need it). The fractions Win uses for limits are outdated. – Astara Aug 26 '17 at 22:26
  • @Astara: They might not be true for you now. Please be careful commenting on answers dating from 6 years ago - technology does evolve. Downvoting today such an old answer is really a waste of your reputation. – harrymc Aug 27 '17 at 7:04
  • @harrymc -- they weren't true 6 years ago either. I've had Win7 since its released date. The behaviors haven't changed. The only answer that fixes (vs. working around it) the problem here (not that it is ideal in that it modifies system files) is the one by nars. Turning off 'desktop composition' doesn't fix the underlying bug in Windows -- its a workaround that has other side effects. – Astara Aug 27 '17 at 15:53
  • @Astara: Well, true enough to fix one guy's problem who rewarded me with a bounty. A better fix might exist, but the best part about our forum is the number of solutions, and it's a given that not all of them work for everybody. – harrymc Aug 27 '17 at 16:54

Is there some reason why Windows is ignoring/forgetting my attempts to suppress the dialog?

No - window should not be displayed again if you answer that, but it happens anyway.

I believe the dialog appears because I'm forcing Vsync and Triple Buffering for DirectX applications.

No, it's not because of that. First of all - Desktop Composition forces system (but not games, they uses DirectX) to work in vertical sync mode and gives you possibility to use nice features like Win+Tab (for example), so disabling it, like many people says, is not a solution, it's method for degrading your system and really bad workaround. Some programs works better with Desktop Composition enabled because of that vsync (like some movie players - it prevents tearing), some works better with Desktop Composition disabled (some window with dot-type borders moves really slow when DC is enabled, also gfx program like old Corel can works much slower), but new programs always works good, so leave Desktop Composition enabled.

For now I recommend to wait until MS releases any fix for that annoying behaviour. For sure do not disable Desktop Composition if you like new Win7 features or Vsync.

  • found that the message was displayed once/binary start. Each time I restarted the binary, it re-asked the question, but then kept the message "disabled" for that 1-binary, for the rest of its run. So dialog was partially suppressed in my case. As for the other -- might not triple buffering use more video memory and contribute to the problem (I would agree that Vsync probably wasn't an issue). – Astara Aug 27 '17 at 0:25

protected by Community Feb 6 '12 at 5:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.