Currently, I have already upgraded to Mac OS X Lion.

But an error occurred (Progress to the last 99%) that when I trying to downloading Windows support software via Boot Camp 4.0.

It says

Can't install Windows Support Software because it is not currently available from the Software Update server

here is snapshot

  • Do you have your Mac OS X Install DVD? – user78429 Jul 25 '11 at 13:39
  • hmmm, I had the same problem, looks like the problem lies with my internet connection – user78429 Jul 25 '11 at 14:02

The download is broken.

install windows then use the install disk that came with your mac, connect to the internet and install all windows updates, then finally update the bootcamp drivers.


Here is what you need to do:

  1. Install the windows 7 partition w/out the windows support first (make sure it is unchecked).

  2. then, once you have installed windows go back to bootcamp and insert your windows 7 cd again.

  3. While the windows 7 cd is in, run the windows support software (hint: do not uninstal your windows partition. make sure that box is unchecked).

  4. half way through the process your windows 7 cd will eject automatically. now you insert a blank cd/dvd and click burn.

  5. once it is done writing the files, restart the mac and run your windows partition.

  6. insert the cd you just created from the blank cd/dvd and you should be able to install all the proper drivers.

Hope this helps. srry im good w/ the technical aspect, but not so good explaining it. it all just works in my head lol. if you already have windows installed then just run steps 3-6 (no need to reinstall windows).


Those 2 answers are incorrect. You cannot install a partition in bootcamp just like that because it will say that you don't have the software or couldn't find the software, I just tested it. Luckly I had the same error as the asker and what I did was just to try to download the support within the bootcamp software and it keep saying error. So I waited and tried again, I think I tried 6 or 7 times at different times, I thought my OS had something lol Once I saw the download was working again, I proceeded with the normal (full) process selecting the 3 of them. To summarize, the download link is not brokes as others described, it works, just try again and again until you get it going. As we speak I'm downloading it.

Here are some useful links too:

https://support.apple.com/kb/DL1630?locale=en_US https://support.apple.com/downloads/macoscomponents

Hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.