Does anyone know how to fix this problem?

The system extension CNQL2410_ClassicNotSeize.kext was installed improperly.

I'm not sure what is triggering the error.


Have a look at the Canon site.

They have uploaded some new Snow Leopard (10.6) compatible drivers as at 9 September 2009.

Seems to fix the problem for me.


It's happening on my Mac too, I think it's something to do with the Canon Scan Gear software and a PowerPC component that won't run because the default installation of Snow Leopard doesn't include Rosetta?

I haven't tried this yet but either install Rosetta (a dialogue will ask you to do this is you launch a PPC app) or see if you can find a Snow Leopard compatible scanner driver on the Canon site.

  • Yeah I've got the Canon Scan Gear software installed also. – ScArcher2 Aug 31 '09 at 13:23

fwiw, i just got the same error message while installing an updated Line6 driver and i do have Rosetta installed. i do also have a CanoScan LIDE scanner and what little turns up on Google suggests that this may the source of the problem. why installing a Line6 driver triggered for me, though, i do not know. possibly a freakish coincidence.


the same message appears after the installation of Vodafone Mobile Broadband GMC on my MacBook (and it don't work with Snow Leopard ...) adriano p.s. I also have a Canoscan LIDE 500 F p.p.s. installing the old Vodafone Mobile Connect I obtained 5 (!!!) Kernel panic ... so, do you know if exists an universal drive for Huawei E272 ?


Sounds like a Canon issue. I too have the CanoScan LIDE 500F and Snow Leopard – however I didn't have any problems installing Snow Leopard, but just now I installed iTunes 9 and got two errors; "System extension can not be used" for both /System/Library/Extensions/CNQL2410_ClassicNotSeize.kext and /System/Library/Extensions/XEROX USB Printing.kext


I got the same error in installing Xcode from the Snow Leopard CD. No problem reported when i upgraded the OS to 10.6, and am running Rosetta.

Also have CanoScan LiDE driver and CanoScan tools installed. They've never worked well; however, Image Capture does work well with my model (500F) and has all the features i was able to access with the Canon tools before Snow Leopard.


This is so weird. I got my 500F working - finally - after installing 10.6 by going into CanoScan and simply looking at the Settings dialog. Once I clicked 'OK' the scanner was recognised and I could use it. Before, nada.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.