I have a really strange problem. I am using Windows 7 Professional with SP1 installed. I have a My Book 500GB external hard drive connected to the network via Linksys E3000. Now in Windows 7 I am logged in as Admin. The network disk is configured in Linksys, that an admin group can r&w. Now I have added this settings to Credential Manager, where I have specified network address of disk, username and password. I have added it, because otherwise the Windows 7 would forget the username & password on restart of the system.

Now the network disk is working without problems. I can access file, write files on it, delete files from it. The problem arises, if I want to delete folder, that contains other files or folders. Now here for some reason it displays this error:

enter image description here

I tried Try Again, it displays Error 0x8007045D (I/O error):

enter image description here

This error is supposed to happen, when there is something wrong with USB port, or USB drivers, but this drive is not accessed via USB, it is a network based disk. Also, I don't have any problems with devices connected through USB, not that it matters in this problem.

Then I clicked Cancel. Now what is really strange about this is, that the folder has gone missing! I will be able to see it again, if I reconnect the network disk, or restart the computer. Now I really don't understand about the permission thing, becuase I am already Admin. I have looked up under network disk properties -> security, and this is want I have found:

enter image description here

As you can see, it seems the account Account Unknown is what controls what can be accessed. It only has Special permission allowed. So I tried to change it to allow everything (which probably would not make a diffrence, because it seems that under that Special permission falls almost everything, as I said I can do everything except delete folders, that contain other files or other folders). When I wanted to apply the Full control that I have selected it gave this error:

enter image description here

It seems that I cannot change this permission. So I wanted to know who exactly is behind this permission, and I got this under Advanced -> Owner:

enter image description here

I guess the Linksys E3000 operates this permission. But as I have said in the first paragraph, I have setted the disk to adming group under Linksys E3000 setup (, which means it has full r&w access.

Now the strangest thing about this thing: I have also another computer, that has Windows XP SP3 installed on it. I also have the network disk added to the computer. The diffrence is, that there I am also able to delete folders, that contain files or other folders. It deletes them without any error.

Also if I connect the disk to computer with Windows 7 on it (the one that I have problem deleting folders that have other folders or files inside it), then I can delete this folders without any problem. I would like to point out, that I also tried this on my second computer (laptop), that also has Windows 7 SP1 installed, and it displays the same error, which means that there must be something with Windows 7, otherwise the Windows XP would gave the same error.

I really don't understand why I am able to delete it from Windows XP, but not from Windows 7. The computer, that has Windows XP installed is connected through Linksys E3000 LAN via UTP cable just as is computer, that runs Windows 7. Please help me with my question and thanks for any answers!

Edit: Adding screenshots of Local Group Policy Editor:

First part Second part

  • Did you create the items you are trying to delete from the XP box? – KCotreau Jul 26 '11 at 17:05
  • No, I created them on Windows 7 computer. – Jernej Jerin Jul 26 '11 at 17:06
  • What firmware version is installed on the E3000? What's the file system format on the MyBook? – Ƭᴇcʜιᴇ007 Jul 26 '11 at 17:22
  • Linksys E3000 Firmware Version: 1.0.04 build 6 Dec 6, 2010. MyBook File System: NTFS – Jernej Jerin Jul 26 '11 at 17:48

Go to command prompt and type rd /s/q directory.

| improve this answer | |
  • Interesting. Tried del, but that does not delete complete folder so I took a look on the Internet and found this command: rd /s/q folder_to_delete. Where rd stands for remove directory. The /s switch is for all sub directories and files in the dir. The /q switch is for quiet mode, which means it wont ask you for confirmation. And it delete files without any problem. If I don't find a solution for deleting folders with files in GUI Explorer, than I will be satisfied with this solution. Please update your answer with rd /s/q folder_to_delete, so that I will accept it if no other solution. – Jernej Jerin Jul 21 '12 at 11:43

The fact that XP doesn't have these problems but Win7/Vista do is a dead giveaway. One of the biggest network changes in Vista/7 was the introduction of SMB v2.0. Along with that, they considerably beefed up the Windows Authentication process for the NTLM.

More than likely, the Samba server running in MyBook isn't up to date compatible with NTLMv2 and/or SMBv2. In general, Vista/7 will balk at older authentication methods that XP was ok with.

Some of the settings you should try. Go to your Win7 gpedit.msc:

  • Biggest one is check the LAN Manager Authentication Method. Vista/7 uses NTLMv2 only. XP can also use NTLMv2, but falls back to NTLM. Switch the setting to Send LM & NTLM. (the Default in XP was actually send NTML only)
  • Network Security: NTML SSP Session security: This is unlikely the solution, but 7 now requires 128 bit encryption
  • Network access: Allow Anonymous SID - Enabled -Domain Member: Digitally encrypt..... (always) This was disabled under XP. XP used the "when possible" option.

I hope some of this helps

Try those two settings and we can go from there

**Edit **

I should probably clarify where I'm going with this. Basically, we are reproducing XP's network security settings one by one on the Windows 7 machine until we see where it hiccups.

All the way to the point where we are just authenticating as anonymous and logging on with a guest account :) It's possible that the software inside the MyBook could just be straight up incompatible with Win7's network security.

| improve this answer | |
  • When you tried to take ownership, the reason it says, "LinksysE3000\Administrators" is because that's how you authenticated with the Mybook. By principle, you can't change ownership to another account, only to your account. So that's how I would troubleshoot your situation. It's likely, the XP machine authenticated through the Everyone group. By default, anonymous connections are put into the Everyone group. – surfasb Jul 26 '11 at 19:57
  • First of all thank you for your answer. Now I will go through your solutions. 1. solution: Had a problem finding the LAN Manager Authentication, so I went looking on the net, I found this:groupes.polymtl.ca/gchit/?page_id=238. I found out, that it was set to Not Defined. So I set it to Send LM & NTLM, as you said, but this did not solve the solution. I wonder if I should set it to Send LM & NTLM – use NTLMv2 session security if negotiated, as the tutorial on that link specifies? – Jernej Jerin Jul 26 '11 at 21:12
  • 2. solution: I have two Network Security: NTML SSP Session security defined, first one is: Network security: Minimum session security for NTLM SSP based (including secure RPC) clients and the second one is: Network security: Minimum session security for NTLM SSP based (including secure RPC) servers. Both have Require 128-bit encryption checked, but Require NTLMv2 session security unchecked. – Jernej Jerin Jul 26 '11 at 21:16
  • 3. Solution: I have set Network access: Allow anonymous SID/name translation to Enabled, was previously Disabled and Domain member: Digitally encrypt or sign secure channel data (always) is set default to Enabled. I do not recognize from your answer, do you want me to disable it? – Jernej Jerin Jul 26 '11 at 21:21
  • Ok I have also tried Send LM & NTLM – use NTLMv2 session security if negotiated, as was recommended in that tutorial two comments above. But with no success. @surfasb: Isn't that really strange, that it would not let me delete a folder in a folder? I mean I would be suprised, if it would not let me delete a file or a empty folder, but this is just plain silly. Please continue with your expertise, I would really like to get to the bottom of this. – Jernej Jerin Jul 26 '11 at 21:38

I suspect that the files on your networked drive are set as "Read Only" - The fix is pretty simple. Right click on a file or folder, click PROPERTIES, then click GENERAL, and in ATTRIBUTES un-click "Read Only" and then you should be able to delete your files (at least most of them). I had the same problem with Linksys3000, a networked hard drive and W7.

| improve this answer | |
  • Interesting. I know that you cannot delete if is read only, but I have not looked under properties. It seems when I create folder and a file inside, it puts the folder under read only. The problem is, I tried to unchecked it, it asks me If I want to apply changes to this folder, subfolders and files. I click OK. But when I close the properties and reopen it, the folder is again checked as read-only so when I tried to delete it, the error that I have described in OP appears. It seems that it sets back to read-only no matter what. – Jernej Jerin Jul 9 '12 at 12:49

It seems to me that you are using an account on XP that has no equivalent account on Windows 7, so Windows 7 calls it "Account unknown" and assigns it some arbitrary permissions on the disk. There have been large changes in account-management going on from XP to Windows 7, so making both share the same NTFS disk is not a trivial exercise.

In addition, the format of NTFS disks is not the same for XP and Windows 7. Windows 7 can understand the XP flavor, but XP might not fully understand NTFS formatted under Windows 7. So if you want to reformat the disk, do it preferably under XP. I would also guess that your My Book would also feel more comfortable with the XP version of NTFS.

In theory the following steps might fix the problem :

  1. Login on XP as THE real administrator. See : Unhide the Administrator Account in Windows XP.
    (I have not tried it, but one hopes that this account is defined the same on both XP/7.)
  2. Branch the external disk directly on XP
  3. Take ownership of the root folder (see this) using "Replace owner on subcontainers and objects"
  4. Delete all other permissions except Administrator off the root folder and add Everyone with total control
  5. Propagate your changes to the whole disk using the root-folder's Properties, Advanced button, Change Permissions button, check "Include heritable permissions from this object's parent", finally OK button.

I cannot promise that you may not sometimes in the future need to repeat again the above steps.

Another idea is to reformat the disk as FAT32. This would be better done on Windows 7, as in Windows XP you can only format FAT32 disks up to 32 GB in size. As FAT32 doesn't store account information, all users will have access to the entire drive, regardless of their account type.

| improve this answer | |
  • Thank you for your extensive solution. The problem is that in the mean time I have got rid of the XP OS on my other computer so I can't try these steps. I will up vote your answer for your effort. I see you have extensive knowledge of Windows OS, please take a look at the @redelman431 solution and my comment bellow, where I used the following instruction rd /s/q folder_to_delete to delete and it worked. Maybe you could explain why is it that this solution in CMD works without any problem. – Jernej Jerin Jul 21 '12 at 11:52
  • The reason is probably that the phantom account didn't have the permission to delete a non-empty folder. The rd command worked recursively, always deleting the contents of the folder before deleting the folder itself, so it it didn't encounter the problem. – harrymc Jul 21 '12 at 13:16

If you have EN windows,add this into your registry,then right button on mouse and select take ownership. after that,you can dele that file. Save folowing code as *.reg
Take ownership:

 Windows Registry Editor Version 5.00

 @="Take Ownership"

 @="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"
 "IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"

 @="Take Ownership"

 @="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"
 "IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"

For removing that from registry:

 Windows Registry Editor Version 5.00



U can run cmd as well.

first run this:

 takeown /f c:\badfile.xxx /r /d y

after that run:

 icacls c:\badfile.xxx /grant administrators:F /t
| improve this answer | |
  • I executed .reg file and the values were successfully saved into the registry. Then I tried to take ownership, CMD displayed and quickly disappeared before I could read what it said. Then I tried to delete folder, but I got the same error. After that, I opened CMD and navigated to that folder and executed instruction for taking ownership. Here is what was returned back (the same was probably returned back when I right clicked and selected take ownership): "ERROR: Access is denied.". It seems that it would not let me take ownership no matter what. – Jernej Jerin Jul 21 '12 at 12:04
  • Please take a look at @redelman431 answer and my comment bellow as it contains a part solution. – Jernej Jerin Jul 21 '12 at 12:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.