I'm using a Logitech G5 2007 Edition mouse with my Mac. I've had it since Tiger, and everything has worked fine. I use the 4th button (the back arrow button) to show all windows in Exposé and I use the 5th button (the forward arrow button) to show the desktop in Exposé.

I've not been using any third party software to configure the mouse, just the Exposé preferences in System Preferences. I won't use that rubbish Logitech Control Centre.

I recently upgraded to Snow Leopard and the 5th button doesn't invoke the show desktop exposé command any more. The 4th button and 3rd buttons work as intended.

I tried reassigning the 5th button to show Dashboard, and that worked! Why? I have no idea.

Basically, after some testing, any mouse button assigned to show desktop doesn't show the desktop. But assigning any other button to any other Exposé command works...

Any help would be great, thanks guys.

  • Same exact problem here with a wireless MS mouse... Aug 30 '09 at 5:56

So the solution I found - after a hell of a lot of googling and research - was that the preferences file was screwed.

If you have this issue (where a mouse button is assigned to a function, but that function doesn't work as expected) simply delete the symbolichotkeys.plist file from your preferences folder and logout and log back in. You can then reset your mouse button assignments and everything should work as normal - no rubbish Logitech or other 3rd party software needed.

The full path is:

  • Only problem is that it only seems to persist for the current session. If you log out again or restart, you'll need to repeat the process... Damn Apple :(
    – Jasarien
    Mar 16 '10 at 11:19

I am using the Logitech Control Center, but I also found that setting buttons to Spaces or Expose didn't work. Instead, I assigned the buttons to the function key which called those commands and it has been working find since.

  • I refuse to use the LCC. It screws with the mouse acceleration curve in a way that makes it so unusable it's unbelieveable. It worked in Leopard, but not in snow leopard. Why?
    – Jasarien
    Aug 30 '09 at 12:15
  • I haven't noticed any problems. I did have to use a backdoor method to install it, though. I have a diNovo Edge for Mac keyboard as well.
    – hanleyp
    Aug 31 '09 at 12:25

It went really fine! I had the same error after updating 10.5 -> 10.6 at my iMac and using a Logitech Laser mouse. After deleting the file in the users folder and immediate logging off and back in I could reassign the button and it works again now! Regards Lars aka Bolti22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.