I have an Icy Dock 3.5" external enclosure with USB 2.0 and eSATA. I have an Intel DG45ID motherboard with USB 2.0 and eSATA ports. In the past I had a 2 TB Seagate drive in the enclosure, and it worked fine via either interface. I just bought a 3 TB Hitachi drive, and it shows up as 746.39 GB!

At first I thought, no problem, the USB storage controller in this couple-year-old enclosure just doesn't support drives over 2.2 TB (a famous limit, apparently). So I switched to eSATA, thinking that this would be a simple pass-through connection and it would work, because the enclosure isn't really doing anything with the interface then. But apparently it isn't so.

I have Windows Vista 64-bit, with the current patches. I initialized the disk as GPT, rather than MBR, as recommended in the GUI for disks larger than 2 TB.

So, what gives? Was I wrong that the eSATA enclosure just passes the SATA connection through unmodified? Is my motherboard to blame? Some drivers?

Edit: I just installed the Intel Rapid Storage software, which updated my SATA controller driver from 8.6 (dated 2-3 years ago) to 9.6 (dated a bit over a year ago). This didn't change how Windows Vista sees the drive, but it did install an "Intel Rapid Storage Technology" application which shows the drive as 3 TB! So, some part of the system sees the full drive size, but not the OS. What gives?

  • id advise checking the changelog of the driver update and see if it actually added GFT support. – Sirex Jul 28 '11 at 4:03
  • GPT is not a driver issue, though, is it? I am under the impression that it's something the OS supports (hence Microsoft saying Windows Vista supports it but Windows XP does not). I did successfully initialize the disk as GPT, it just shows the wrong size. – John Zwinck Jul 30 '11 at 15:28
  • In the BIOS is the drive setup as IDE, AHCI or RAID? Might want to switch to RAID (even if its a single drive). – Brian Aug 1 '11 at 13:54

From what I've read, you need an even newer version of the Rapid Storage Technology driver, version 10.1 or newer. Looks like 10.6 is now available.

The main problem is that the combination of your BIOS, OS, and storage drivers don't know how to handle drives with that many 512-byte sectors on it (the Hitachi 3TB disk doesn't have a 4KB sector size, unlike some other > 2TB drives). By updating the storage drivers to something new enough, it can handle the OS/BIOS special interactions better.

  • I downloaded 10.6, but it says my computer does not meet the minimum requirements. Not sure why--I think I have an ICH10R (my mobo is Intel DG45ID, and the Device Manager in Windows says I have ICH10--it doesn't say R). – John Zwinck Aug 13 '11 at 14:57
  • ...and then I went into BIOS and changed my controller from "IDE" to "AHCI" and now the driver does install. We'll see.... – John Zwinck Aug 13 '11 at 15:12
  • It worked! So from where I started to the finish, I had to do two things: change "IDE" to "AHCI" in BIOS, and upgrade to 10.6 (or at least newer than 9.6) of the Intel storage drivers (despite them not being posted on the downloads page for my particular motherboard. Thank you! – John Zwinck Aug 13 '11 at 15:45

The famous 2.2TB limit applies to all volumes on a Microsoft system, internal or external, regardless of the connector. For more information, see here:


  • 2
    The link you posted applies to MBR only. As I said in the OP, I initialized the drive as GPT. Unless you can be more specific, I don't think you are right that the 2.2TB limit applies to all Microsoft systems. – John Zwinck Jul 28 '11 at 2:59
  • He is correct, it applies if there is MBR partitioning and a BIOS based system. It does not apply to an MBR (that much be much smaller I belive) – soandos Jul 28 '11 at 3:03
  • @soandos: Who is correct, me or Yitzchak? – John Zwinck Jul 28 '11 at 3:16
  • Sorry I didnt make it clear, Yitzchak. I am not 100% sure though, just m reading of the article though. Also, does not apply to win vista (i think, least i didn't say that in the article). In other words, I think his reading of the article makes more sense, but I am not sure it applies to your OS. – soandos Jul 28 '11 at 3:37
  • 5
    The 2.2TB limit is only for Microsoft systems that are not 64-bit. Vista 64, Windows 7 64, 2008 and even 2003 64 support greater than 2.2 TB drives for data and boot. – skub Aug 6 '11 at 21:35

The limitation is in the traditional BIOS based system - it can only handle 2.2TB. UEFI systems can use the GPT and are not limited. So, the limitation is not the OS. Swap your motherboard out or check if intel has a BIOS update (but i doubt this, totally different systems) to get 3TB support. I recommend Asus boards if you have to buy something.

EDIT: I missed the part where you said the tool saw 3TB. Did you format the drive using MBR or GPT?

Go to control panel > administrative tools > computer management > disk management

From there you can reformat and repartition the drive. I know MBR and GPT are formatting options in windows 7 64.

This explains everything and is written by people who know- Hitachi.

Article about UEFI and 3TB

  • I initialized the drive as GPT. It still reports the small size. – John Zwinck Jul 28 '11 at 13:00
  • Post 3 points to a BIOS setting that needs to be in place. It also claims issues with your motherboard and > 2.2TB drives. I would also like to suggest that you boot to a gparted CD and see if you can format from there. communities.intel.com/message/108435 – skub Jul 30 '11 at 22:13
  • @BIOS systems can only boot from an MBR disk but can have GPT connected to them. – Synetech Aug 1 '11 at 0:17
  • @skub: Thanks for the link, but post 3 there looks to me like it's talking about booting from the large disk. I'm not trying to boot from it--just use it for data. – John Zwinck Aug 2 '11 at 2:39

Your problem is probably that Windows does not support GPT for removable media.

From Windows and GPT FAQ, dating from June 15, 2011, section Windows Disk Support :

Q. What about removable media?

A. Removable media must be MBR or "superfloppy."

As far as I know, there no way around this limitation, so you are stuck with not using your entire external drive, unless you convert it to internal. What you are seeing is the "protective" MBR header and only a part of the disk, rather than the real GPT partition.

If you cannot format the external drive as MBR with 2.2 TB, then the disk's firmware may be damaged. I hesitate whether to point you to the article Restore factory Hard Drive Capacity, since the utility described there can brick your drive.

  • I actually don't think the OS sees the drive as external at all, when I'm using eSATA. For example, it does not appear in the list of devices I can select to safely remove (as it does if I use USB). Also I would like to note that there are 3TB USB drives which claim to work--just not my particular enclosure's USB controller. – John Zwinck Aug 1 '11 at 3:18
  • You are right - eSATA is treated as an internal drive. Could you add to your post how you formatted it as GPT? Were there any existing partitions on it before that? – harrymc Aug 1 '11 at 6:06
  • I initialized it as GPT by going to the Windows Disk Management MMC snap-in, which immediately prompted me because I had a new, uninitialized disk. It said I should choose GPT for disks over 2 TB, and I did that. I never actually formatted the drive (e.g. with NTFS) because the size of the partition was too small in the first place--no point formatting it when it's 7xx GB. The drive was brand new when I started. – John Zwinck Aug 2 '11 at 14:52
  • I have added another answer. The only point left in this answer is whether the disk may be damaged. You could try it internally or on another computer, to test if it is damaged. – harrymc Aug 2 '11 at 15:32

Quoting from Paragon GPT Loader :

2.2TB+ drives appear to be supported by new Windows OSes (Vista and later) at first glance, but other system software could limit their support. One particular situation includes Intel Storage Matrix Drivers for HDD controllers, which will not allow full access to the entire disk in all systems where present.

Paragon GPT Loader includes a special driver that overrides native Intel drivers, thus providing full unrestricted access to 2.2TB+ drives under Windows Vista and later OSes.

Note! The current version of Paragon GPT Loader cannot help you to accommodate Windows OS on a 2.2TB+ drive. Its main purpose is to provide access to 2.2TB+ drives connected internally as a secondary device under any Windows OS since XP. Only internally connected single 2.2TB+ drives are supported, not external storages, or those combined into RAID (Redundant Array of Independent Disks).

I have no experience with Paragon GPT Loader, but it seems to be addressing the very problem that you are facing. It also does not seem to have a trial version, and it costs $19.95.

While I do not advocate buying this, you might email their Sales at sales@paragon-software.com to ask for a trial. Don't forget to mention that you have Vista 64-bit.

See also the before-last answer in Win7 SP1 64-bit only recognizes 746GB of Hitachi 3TB drive , where the problem was the Nvidia SATA driver.


I had the exact same problem with a Sans Digital eSATA RAID w/6TB of storage. On both Win7 64 and Server 2008 R2 it only showed up as 1.5TB. I also chose the GPT option when prompted. However, this device supported both eSATA and USB. I plugged the RAID in USB and was able to create and format a volume with the full 6TB. Then, I reconnected it as eSATA and it came up with no problem.

I know that is more of a workaround than a solution and I can't tell you the root cause, but it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.