I'm trying to disconnect from a wireless network, but whenever I click "Disconnect", nothing happens. See this video:


I've tried to disable it, and re-enable it but this doesn't work. I've also tried pressing the button on the laptop and this didn't work either.

  • Does that happen when you try to click anything else? Has it been happening for long? – KCotreau Jul 28 '11 at 11:30
  • What type of connection is it, and what type of connection is the one above? – soandos Jul 28 '11 at 12:07
  • Looks almost like a stuck mouse button or keyboard key. – KCotreau Jul 28 '11 at 12:52

Make sure you have the Connect automatically when this network is in range checkbox UNCHECKED in the properties of this connection. Open the Network and Sharing Center > Manage wireless networks, then select the network and right click to get the properties.

enter image description here

You could removing the network from your wireless networks list if you open the Network and Sharing Center > Manage wireless networks, then select the network and click on Remove. You could also try deleting the network...

enter image description here

  • I can't uncheck the connect automatically box because it says only the administrator can change it. Although i am an administrator, shouldn't there be a shield next to it and i have to allow the action through UAC? – ErikTJ Jul 28 '11 at 13:39
  • You might try turning off UAC. [link] (windows.microsoft.com/en-US/windows-vista/…) – tekNorah Sep 9 '11 at 19:56
  • Also, is it possible that you have another wireless manager installed for your wireless adapter? Have you tried creating a new user on the system? With the other user, are you able to disconnect from the wireless network? Did you try updating the drivers for your wireless adapter? – tekNorah Sep 9 '11 at 20:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.