Bottom-line, I can only get one monitor to work at any given time. If I hook Monitor 1 to the DisplayPort and Monitor 2 to the D-DVI, only Monitor 1 will display a picture. Windows recognizes Monitor 2, but it won't display a picture. So, it seems I can only run the DisplayPort OR the D-DVI connection, not both.

I have a feeling this has something to do with HDCP, but I'm not sure. Any help would be greatly appreciated.

Update I know the cables and second monitor work fine, because I swapped them all in, out, and around. Still, only one monitor at a time. I know the D-DVI port works fine, because I can run one monitor off of it.

  • What does "Windows key + P" do? – Stack Overflow is dead Jul 28 '11 at 19:06
  • Nothing. I have it configured to extend the desktop, but the screen is blank. But, if I bring up the display configuration, I have two monitors. Thanks for the suggestion ... – Josh Jul 28 '11 at 19:37
  • Since Display Port is backward compatible with DVI-D via level conversion, some graphics card let them share the same digital output from the GPU. This means, only one of them can be working at the same time. I doubt this is the case in your card though, as you don't have any VGA port and your GPU should be capable of two digital output. Do you have any luck with nVidia control panel? Maybe you want to try dual-link DVI instead. – billc.cn Jul 28 '11 at 21:35
  • billc- I have tried the nVidia Control Panel. There is an option to "Check HDCP Status" and if I click on Monitor 1 (connected via D-DVI) it says "Your graphics card and display are HDCP capable", if I click on the second Monitor (connected via the DisplayPort->DVI adapter) it says "Your display does not support HDCP". – Josh Jul 28 '11 at 21:52

I think you need to have an active display port. Something like this... http://www.newegg.com/Product/Product.aspx?Item=N82E16814999030

| improve this answer | |
  • Stephen- Thanks. I should have listed that I currently have this adapter, but it doesn't seem to make a difference. – Josh Jul 28 '11 at 21:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.