I am trying to resize a 160GB disk to fit on a 80GB disk,

I have tried 3 times to shrink my NTFS and resize the partition. Im using backtrack as a live CD to do this,

I use ntfsresize to the filesystem to 60GB Then I use fdisk to delete the partition and then create a new partion starting at the same point but finishing at 60GB, I mark the partition bootable and give it an ID of 7 which is for NTFS then I write it to disk and reboot, I then get,

"Operating system not found"

So then I used ms-sys to repair the MBR which it said was successful, But now when I boot I get

"Error loading operating system"

Any Ideas, luckily I have clonezilla backup of the 160GB disk and I just keep reimaging and then trying again but im stuck as to how to get it to work,

  • Did you put fdisk into sector mode ( -u switch or the u command )? If not then you probably did not recreate the partition with the same start point since it probably wasn't originally on an even cylinder boundary. – psusi Jul 29 '11 at 14:19

I do all of my partition resizing with a Parted Magic Live CD or USB stick and it's not let me down yet - it's a single-step operation in a GUI environment and there's no need to shrink manually and then use fdisk.

Might be worth reinstalling your image and giving it a try.

PS: Kudos for actually keeping a backup before trying the operation - many don't!

  • Downloading now.. Ill give it a go and let you know thanks for the pointer – squareborg Jul 29 '11 at 12:13
  • That completely worked plus it shows you all the commands its running. I dont know why I constantly do things the hard way! – squareborg Jul 29 '11 at 13:13

I just used GParted to do this successfully on an Ubuntu system, for both vfat and ntfs filesystems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.