Receiving a new batch of PCs prompted us to recapture our WDS image for our on-site Windows 7 machines. Rolled into the new image (i.e. the only changes that have been made since the previous version of the image) was the suite of drivers, Adobe Reader upgraded from 9.13 to 10.0 and the exclusion of Microsoft Access.

When we deploy this image to a PC we now get two hard drives appearing in Explorer.

Windows 7 Explorer

This second disk, when viewing the properties, is an exact clone of the "real" hard drive (these machines only have one installed). This phantom drive is full of what looks like temp/log/cache files.

Windows 7 Explorer - Z Drive

Edit: Disk Management shows only one disk assigned one drive letter.

Windows 7 Explorer - Disk Management

We have tried uninstalling Adobe after deployment, but the problem persists. Is there any way to remove this drive (so our users don't try storing documents in there thinking they have a second drive installed)?

  • How about a screenshot of your disk manager. That would possibly really help.
    – KCotreau
    Aug 2, 2011 at 3:57
  • @KCotreau, screenshot of disk manager added, including drive letter assignment.
    – Windos
    Aug 2, 2011 at 4:12

2 Answers 2


Open a command-prompt (cmd.exe) and run subst; you should see something like the following:

Z:\: => C:\Users\JOSHUAK\AppData\Local\Temp


It means that the drive letter ‘Z’ is mapped to your temp directory (it might be the system temp directory C:\Windows\Temp instead of your user temp directory C:\Users\JOSHUAK\AppData\Local\Temp).

You can delete the mapping as follows.

C:\subst z: /d

Your next task is to figure out where the mapping is being done. Try a tool like Autoruns.

  • Perfect, exactly what I was looking for.
    – Windos
    Aug 2, 2011 at 4:29
  • 1
    To anyone interested, the cause was the latest version of UniPrint (which had been updated on existing PCs, but freshly installed for the new image.)
    – Windos
    Aug 18, 2011 at 0:44
  • 1
    Are you saying that UniPrint adds a subst? That sounds pretty odd and unlikely (and as a programmer, I have to say kind of lazy, if true).
    – Synetech
    Aug 20, 2011 at 0:45
  • I'm pretty sure it wasn't intentional. But to stop the automatic mapping we had to add "DriveMapping"="0" into [HKEY_CURRENT_USER\Software\UniPrint\Client] (communities.uniprint.net/forum/viewtopic.php?f=9&t=60)
    – Windos
    Aug 20, 2011 at 0:52
  • Really? That worked? There wasn’t a batch-file or Run reg-entry or other startup item doing it? If the only change required was indeed that one, UniPrint-related key, then it sounds like it was indeed doing it on purpose. There are better, more proper ways to map drives; subst is a user tool (granted, apps can use it, but it’s lazy, particularly for a commercial program).
    – Synetech
    Aug 20, 2011 at 1:38

I just want to clarify, since use of subst is not recommended and many folks will not understand the difference between a mapped drive and a subst.

Subst does not map a drive. That is done with net.exe and refers to assigning a drive letter to a network drive. Subst basically creates an "alias" (that's not the technically correct term) for a path on an existing drive. You can subst to a mapped drive. For instance, you can map (using net.exe) a network drive as drive K:\, create K:\MyStuff and then subst M: K:\MyStuff.

As mentioned, although subst still exists and works fine, use of that is generally discouraged.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .