We all use editing facilities to change a line of text as we are entering it. There are two principal editing modes within a line, a) "insert mode" which inserts non-editing characters at the point of the cursor, and shuffles text to the right, and b) "overwrite mode", in which non-editing characters simply overwrite whatever character the cursor selects.

Overwrite mode IMHO is left from the days of green-screen CRTs. The only use I have ever found for it is drawing 2-D pictures in ASCII, which I quit doing back in the 80s when real drawing tools became available.

Windows (stupidly IMHO) offers overwrite mode toggle-enabled by use of the INSERT key on the keyboard. (I'd guess Linux/Unix likely follow suit in the usual Windows-envy). I don't ever hit that button because it just puts me in overwrite mode.

However, as I'm typing sometimes Overwrite mode suddenly happens. I think it must be some strange combination of ALT/Windows/CTRL/SHIFT and some other key, or two standard keys depressed in time nearby. Does anybody know what the alternate key sequence is so I can try harder to avoid it? Is there a way to tell Windows to simply stop using Overwrite mode?

  • 2
    It appears that Shift+Numpad0 puts one in insert mode. I think this is the actual cause of my problem. (Does anybody on the planet actually use insert mode?) – Ira Baxter Sep 10 '14 at 10:57
  • 1
    I'd like to add (even though this is off-topic) that upon experimentation, I found that it isn't just Shift+"Numpad 0". Shift+Numpad seems to disable the effect of Num Lock, so we also have Shift+period (delete!), 1, 2, 3, 4, 6, 7, 8, and 9 all doing their other equivalents. I wonder if this is specific to Microsoft Windows, or generally supported by other software, or perhaps a keyboard-thing (that requires no special software support, because it is handled by keyboard scan codes). – TOOGAM Oct 6 '15 at 18:34
  • The accepted solution didn't work for me on Windows 8.1 (though a related question about how to disable Caps Lock did). – AlainD Mar 24 '16 at 23:00
  • MS Office disabled the key by default after so few people use it. Actually I still sometimes need to draw 2D tables in ASCII, for example to post on stackexchange, but there are tools for creating the table so overwrite no need for overwrite mode. – phuclv Nov 26 '16 at 10:44
  • "anti-functionality". I like it! – Stephen Hosking Nov 15 at 0:40
up vote 23 down vote accepted

How to Disable the Insert Key in Windows

Almost anyone who has used a wordprocessor has accidentally hit the Insert key and overwritten when they thought they were editing. This article describes a simple way to disable the Insert key on your keyboard.

Whenever you press a key, a windows message is created, which contains a key code that uniquely identifies the key pressed. Programmes (like Microsoft Word) look for keypress messages and take actions based on the key code in the message. By mapping the insert key press event to null, windows send a message containing null for the key code when the Insert key is pressed. Programmes receiving the message, therefore, do not perform the action associated with an insert key press event, freeing you from having to worry about overwriting things again.

  1. Go to Start → Run → regedit
  2. Go to HKLM\System\CurrentControlSet\Control\Keyboard Layout
  3. Right-click on the right half of the screen and choose New → Binary Value
  4. Name the new value Scancode Map
  5. Enter 000000000000000002000000000052E000000000
  6. Close regedit
  7. Reboot.
  8. Optional: you can take the Insert key off of your keyboard when done.

If you do this with Windows7 regedit, you have to enter the hex value in rows of 8 bytes, like this:

Value Data:
0000    00 00 00 00 00 00 00 00
0008    02 00 00 00 00 00 52 E0
0010    00 00 00 00

Source

Registry file (.reg) to apply the fix as described above

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,00,00,52,e0,00,00,00,00

Put the above text into a file with a .reg extension (e.g.: disable-insert.reg), and double click.

  • I never gave any credit for this. My bad, so "accept" now. – Ira Baxter Feb 26 '14 at 4:08
  • This can be done less manually/dangerously by using SharpKeys - see dangph's answer below – rattray Apr 23 '15 at 7:49
  • 1
    Just remember to reboot after this.. – pootzko Jul 12 '17 at 10:53

The 0 key on the numeric keypad becomes insert when num lock is off.

When you type something in an MS-DOS application and go back to the middle of the phrase and press TAB, you switch to overwrite mode.

  • 2
    You mean the 0-key on the numeric keypad is the insert key when num-lock is off. – Dennis Williamson Aug 30 '09 at 13:07
  • +1 for pressing Tab. I was wondering why overtype kept getting triggered in Powershell... It's because I press Tab all the time for autocomplete – binaryfunt Apr 21 '17 at 22:50
  • Also make sure "Insert mode" is ticked in the Powershell settings – binaryfunt Aug 18 '17 at 11:37
  • This is what saved me quickly without spending more time than necessary on any of the other answers. I have no Insert key and had accidentally hit the 0 on the numeric keypad. I just hit it again, and bingo-bango, the day is saved. – rubynorails Apr 17 at 20:50

Just figured this one out... Shift+0 on the numeric keypad. I guess I must accidentally tag it while speed typing often enough. Has been throwing me for a long time.

While my addition above may be helpful to some, that wasn't my problem. Anyone stumbling here, if this happens pretty much no matter what app you may be in (i.e., not solely to do with editing in MS Word), save yourself the aggravation of searching to the end of the internet like I have...

Edit:
My personal definitive conclusion is that there is no "other magic key combo" for toggling insert overwrite, period. So therefore the only remaining possibility is that in the course of rapid typing, either due to an imperfect/sloppy stroke combo OR a bounce on the keyboard aiding in such, an unexpected encoding is generated that happens to always trigger ins/ovr toggle. I gather from my personal research that it is more likely due to a keyboard/hardware flaw than a software flaw. If it was a software flaw I think we'd see more posting on the net about it.

I am going to finally try the regedit suggestion posted, and simply try to get over it now.

Use SharpKeys to map Insert to Turn key off. This disables the key and is easier and safer than doing the registry hacks yourself.

Sharpkeys is old (it's designed for Windows 7) but still works on Windows 10.

enter image description here

  • I discovered SharpKeys a couple years back (look at date of question) but didn't remember I asked this question. So, +1 for answering with an excellent answer. Guilt made me accept (just now) a much older answer which I used before I found SharpKeys. – Ira Baxter Feb 26 '14 at 4:10
  • @Ira, no problems, thanks for the upvote :) One thing that SharpKeys won't do, I've just discovered, is it won't disable Shift+NumPad0. I recall that there is a hotkey editor out there somewhere. That might do the trick. But I never hit that key combination accidentally, so it doesn't affect me. – dangph Feb 26 '14 at 4:21
  • Over long usage (note the age of this question), I've discovered that I do hit "Shift+NumPad0" by accident occasionally. The fact that this is really rare means it takes me some time to recognize it, and, since I'm in insert mode with the insert key disabled, it isn't obvious how to get out again. Eventually shift+Numpad0 comes to mind. The rare events are the worst to handle. So, I need a stronger answer. Sigh. – Ira Baxter Sep 10 '14 at 10:55

I'm surprised nobody suggested the simplest solution - take out the actual physical key out of the keyboard (eg. with scissors, knife).

enter image description here

  • 2
    Because that's unsightly... – binaryfunt Apr 14 '17 at 17:14
  • You are not supposed to look at the keyboard anyway while typing ;-) – rluks Apr 15 '17 at 18:17
  • 2
    Please, no one do this. – bubbleking May 22 '17 at 3:23
  • That's what I've done, and been happy with it. I can still accidentally press Num-0, and that puts me into insert mode. I have to press it again to exit it. – Stephen Hosking Nov 15 at 0:42

Go to File - Options - Advanced - Use Insert Key to Paste - It will still be used but for a much more practical reason and you will notice when you have pasted something you don't want :-)

  • I assume this is for some particular application (probably Word)? The question was about disabling the functionality in Windows completely. – kad81 Aug 24 at 0:16

One of the easiest ways to fix this problem, and also give yourself some other useful functionality, is to remap the insert key using AutoHotkey.

On my Windows machine the number pad does the insert key if the numbers pad is not locked, so I have the following in an AutoHotkey script:

Numpad0:: 0

So if I end up hitting the 0, it is writing out 0 instead of being an insert key, and I don't have to worry about having the numbers lock on or off.

protected by Community Oct 13 '15 at 18:14

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.