1

For some reason, many command I try to execute I get command not found I've tried touch, mkdir, sudo, ln -s all the same result

ilyas-mac-pro:~ ilya$ mkdir bla
-bash: mkdir: command not found
5

You changed your $PATH (more about it). Try to enter the full path of commands, e.g. /bin/mkdir (or /usr/bin/mkdir, not sure right now).

echo $PATH to see the current path variable value.

export PATH=/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/X11/bin for a sane value.

Check your shell init files, e.g. .profile or .bash_profile for lines like the export PATH=... above and remove them.

  • To add to Daniel's answer, the proper default for $PATH in OSX is /usr/bin – Yitzchak Aug 3 '11 at 16:06
  • @Yitzchak: The default PATH on OS X 10.6 is /usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin. It should always include at least /usr/bin:/bin:/usr/sbin:/sbin since the "standard" system binaries are spread between those 4 directories. – Gordon Davisson Aug 4 '11 at 4:51
  • I stand corrected. I haven't used OSX since leopard. – Yitzchak Aug 4 '11 at 15:59

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.