1

My MBP fails to boot Arch. This is what I did to install ArchLinux.

Install rEFIT.
Partition using disk utility such that first one is Mac partition, second is Arch & the third ie the last one is windows.
Then put Windows 7 CD, select it from rEFIT and install it.
Similar, install ArchLinux just as I did for windows.
Then finally to install the GRUB, I issued the command $grub-install --root-directory=/mnt/arch --recheck /dev/sda3 (after mounting my /dev/sda3 to /mnt/arch).

This is the exact error and then it drops to recovery:

enter image description here

Error after typing exit:

enter image description here

I have tried rootfstype too. No success.

My menu.lst (I have tried /dev/sda3 too):

enter image description here

  • When your get to the recovery console, are you able to run fdisk -l? If you can, please edit and post the results. – Joe Internet Aug 4 '11 at 8:23
2

Removed autodetect HOOK and created the kernel image & now it boots.

0

I think you have put a wrong entry in grub...put the correct entry for root section of the grub entry.You said arch is in 2nd partition right?? Then it should read like below

root (hd0,1)

Grub is not able find you disk partition containing Arch install;so drop you to a recovery shell.

The error msg also said that no /dev/sda3 partition exist!!! how did you install Arch??

  • I had to remove autodetect hook to boot? Can you tell me how did this help? – Abhijeet Rastogi Aug 4 '11 at 7:50

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.