I am trying to install a software on Win 7 but the installation fails giving this error:

There has been an error. 
Error Running C:\Program Files\BitNami Trac Stack/pythonPackages/installpython.bat:   
'msiexec.exe' is not recognized as an internal or external command, operable program or batch file. 
The application will now exit.

However the same installation is successful on another device with similar OS.

How do I rectify this ?


As figured out from the below discussion with @Diogo_Rocha, the problem may be due to having a 64 bit CPU but with 32 bit Windows 7 installed on it.

But I still haven't found a way to recify this issue since I am not in a position to re-install WIN 7 X64 after performing a complete wipe up on my computer

  • 1
    Could you please check what happens when you do the following: Click the Start button and enter into the field Search programs and files the command cmd.exe, then press Enter. When the black windows appears, please enter msiexec.exe and press Return again. Does a new window open or does it throw the same error message as with the batch at you? – Tex Hex Aug 4 '11 at 16:47
  • @TeX HeX : Thanks.. I tried it out but I get the very same error message – Rajat Gupta Aug 4 '11 at 18:04
  • Actually there is an issue that might be probably affecting this which I figured out from the discussion with @Diogo_Rocha below. I have a 64 bit CPU but 32 bit Windows 7 is installed on it.. :( – Rajat Gupta Aug 4 '11 at 18:07

Based on the comments, there is no 32 / 64-bit problem.

Maybe the problem is as simple as that Windows can not find MSIEXEC.exe

Could you please open a command prompt and enter SET PATH. There will be a long list of directories, separated by ;. Can you please verify that the directory C:\WINDOWS\SYSTEM32 is included in this list?

You might need to copy the entire output to Notepad to line up all folders and verify that ...\System32 is in the list.

| improve this answer | |
  • I get this message Windows cannot find 'c:\Windows\SysWoW64\cmd.exe' Make sure you typed the name correctly and then try again. – Rajat Gupta Aug 4 '11 at 20:15
  • 1
    Okay, then let us verify this: Click Start, enter system and then click System Information in the Programs list. Inside the appearing program, what does it say for the entry System Type? If it says "x64" than you have a 64-bit Windows version. – Tex Hex Aug 4 '11 at 20:27
  • It says System Type: X86-based PC – Rajat Gupta Aug 4 '11 at 20:29
  • 1
    Okay, then we have a complete different error here. When you execute this on the PC that is working, does is also say X86-based PC or something different? – Tex Hex Aug 4 '11 at 20:37
  • 1
    Yes, that's the PC that I wanted to know about. This means, we are having a complete different problem here and no 32/64-bit issue. Let me update the answer, I have another idea. – Tex Hex Aug 4 '11 at 20:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.