244

In Snow Leopard the Play / Pause media button (on the F8 key) opens up iTunes. How can I disable that? Preferably keeping the old Leopard behaviour, so I can use it to control other media applications (e.g. Spotify).

  • 2
    Apple forum thread about the issue: discussions.apple.com/thread.jspa?messageID=10075555 — no solution though. (Even if the page strangely claims "This question is answered") – Jonik Aug 30 '09 at 12:57
  • 1
    Another unclosed thread on this: forums.macrumors.com/showthread.php?t=757430 – August Lilleaas Aug 31 '09 at 9:34
  • 3
    This one is loaded with good solutions: discussions.apple.com/… – Darren Newton Sep 18 '09 at 1:01
  • 14
    @AugustLilleaas It is not fixed in Lion! – Jonathan. Sep 25 '11 at 13:13
  • 2
    @Dag Høidahl This is NOT fixed in mountain lion & mavericks. The media keys are bound to the last active media application. Ie. you are using spotify with the keys and it works fine. You pause spotify, play a video in VLC, then close VLC. Now the media keys are still bound to VLC because it's the last active app. However, you have closed VLC so the binding is lost. Pressing the play key now opens itunes again instead of controlling spotify. – Maurice Jun 27 '14 at 8:51

27 Answers 27

26

a better temporary fix is to start quicktime and just have it running(not playing a movie) in the background. It uses less ram/cpu than iTunes.

  • Indeed, this is a slightly better work-around – Jonik Sep 12 '09 at 21:29
  • 5
    I've accepted this answer as it is the easiest and least problematic of the solutions. – Olly Nov 10 '09 at 15:47
  • This does not appear to work on Lion, iTunes still opens for me, regardless of if Quicktime is open or not. – MrDaniel Jul 28 '12 at 14:57
  • See answer from @bernk from 17-Oct-2014 that has a simple fix that survives new versions of the operating system and is simple and correct. – Tom Harrison Jr Jan 15 '16 at 20:12
  • here's a similar fix, if you happen to use google chrome and have it always opened: install google music app. or any chrome extension that will "hijack" the media keys, such as sway or streamkey. only thing is they might bring some problems of their own. now I'm wondering how to fix this once and for all. – cregox May 12 '17 at 1:51
162
+50

Update: There is a GUI available that performs the below steps, at the official website.

Fixing this is very simple. While the installation process does involve using Mac Terminal, you do not need any knowledge of it. I have included images to make it easier! Just follow 6 simple instructions below and you are done!

  1. Download this zip file
  2. Unzip the file
  3. Run the Patch.command file (Double Click It)
  4. It will open mac terminal. It will most likely prompt you to enter your password. Type your password and press enter. It should look similar to the image below:

    step 4

  5. At the bottom it will say "Everything is ready. Would you like to create a backup and apply the patch (y/N)". Type y, then press Enter. It should look similar to the image below:

    Step 5

  6. You are done! It should output some text and say [Process Complete] at the bottom. You can then close the mac terminal window. The process completing successfully should look similar to the image below:

    Step 6

Uninstall

If you want to remove this patch, simply run the Patch.command script again.

Here is the github repository Thanks to thebitguru for this script.

  • 1
    And runs great on Lion too! – Jari Keinänen Sep 28 '11 at 19:04
  • 9
    Binary moved here: nomitsu.com/contents/MMFix.dmg Works great on 10.7.3 Lion! – Pavel Alexeev Feb 4 '12 at 15:01
  • 6
    Still works in Mavericks! – fgb Mar 3 '14 at 22:02
  • 3
    Is it known if this works on Mavericks or Yosemite? – Tango Oct 8 '14 at 7:27
  • 4
    Works on Yosemite – Alex Oct 27 '14 at 2:17
117

The real solution: Open Terminal, paste in the following line, and hit enter. You're done. To undo, change unload to load in the same line.

launchctl unload -w /System/Library/LaunchAgents/com.apple.rcd.plist
  • 4
    This is the correct answer. Ty! :) – arcastro Sep 21 '15 at 11:24
  • 7
    This works on El Capitan, but it doesn't forward the play button event to the actively playing application – w00t Dec 11 '15 at 13:21
  • 2
    This is the best solution and works on El Capitan! – JeroenJK Dec 21 '15 at 17:28
  • 11
    This will completely disable the remote control device (rcd), if I am not mistaken. Which will not allow you to use your mac remote control, if you have that. – Magne Feb 11 '16 at 14:15
  • 7
    It doesn't work anymore on MacOs Sierra... Too bad I liked having a simple command to do that. – NitroG42 Sep 21 '16 at 9:06
48

For controlling Spotify, use Shift + Option + Play button. iTunes does not react to this combination, but Spotify does.

  • 2
    Indeed, you are right, +1. However, this is starting to get a bit unwieldy as I like to have the "standard function keys" option on, i.e. I need to press 4 keys: Fn + Shift + Option + Play :P – Jonik Apr 22 '10 at 18:44
  • This tip also works for controlling Rdio. – Paul Lefebvre Oct 19 '11 at 0:07
  • ++ Nice simple workaround. Too bad it isn't more intuitive. – Garen Checkley Jun 14 '12 at 15:06
  • kinda annoying having to use modifier keys, but hey, if it means i don't have to open something else up or keep closing itunes then I'm happy – andyface Dec 7 '12 at 12:59
  • In Mountain Lion (at least version 10.8.3), this behaviour seems to be fixed. When Spotify is open, iTunes does not open anymore. – Dag Høidahl Jun 3 '13 at 21:15
19

andrew px and dmonner wrote an excellent workaround here: http://discussions.apple.com/thread.jspa?threadID=2122639&start=30&tstart=0

It uses a python script and some renaming to prevent iTunes from opening when applications of your choice are already open:

Open a Terminal and type the following

cd /Applications/iTunes.app/Contents/MacOS
sudo mv iTunes iTunesX 
sudo curl http://www.cs.umd.edu/~dmonner/iTunes -O
sudo chmod uog+x iTunes 

From http://www.cs.umd.edu/~dmonner/iTunes

#!/usr/bin/env python

import sys, os, subprocess

launch = True
blocker = ""

apps = ["Spotify", "Songbird"]

ps = subprocess.Popen("/bin/ps -x", shell=True, stdout=subprocess.PIPE)

for line in ps.stdout.read().split("\n"):
    for app in apps:
        if app in line:
            launch = False
            blocker = app

ps.stdout.close()

if launch :
    os.spawnvp(os.P_WAIT, '/Applications/iTunes.app/Contents/MacOS/iTunesX', sys.argv)
else :
    print "Not launching iTunes while %s is running." % blocker

Add whatever application you need to the list apps = ["Spotify", "Songbird", "your app here"]

  • 1
    I've done this in the past, but Apple Update likes to overwrite it. This last time I tried making the file system and userimmutable, we'll see if Apple Update respects that flag. I cant really test it until a new update is available, but if anyone else wants to try it: sudo chflags uchg /Applications/iTunes.app/Contents/MacOS/iTunes sudo chflags schg /Applications/iTunes.app/Contents/MacOS/iTunes If you want to disable that (e.g to actually update): sudo chflags nuchg /Applications/iTunes.app/Contents/MacOS/iTunes sudo chflags noschg /Applications/iTunes.app/Contents/MacOS/iTunes – user16315 Jun 1 '10 at 19:35
  • 1
    Upvote this, zomg! – August Lilleaas Oct 9 '10 at 19:39
  • 1
    This is fantastic. – Jake Feb 12 '16 at 19:55
6

Renaming iTunes only works until OS X finds it again. I deleted it from Applications and a couple of minutes later it was found on my backup disk and the problem returned. Deleted it from there to, no more problems. Don't forget to emty the Trash, or it will probably be found there...

So, deleting all copies works fine for me. My music is flac so I have no use for it anyway.

  • 1
    I'd hope there was some solution also for those of us who use iTunes (too), and don't want to delete it... – Jonik Sep 1 '09 at 6:11
5

I have a 'workaround':

  • Quit iTunes
  • Locate iTunes.app in Finder (In Finder: Menu › Go › Applications...)
  • Ctrl-click on the iTunes.app-file and select 'Compress "iTunes.app"' (for backup)
  • Ctrl-click on the iTunes.app-file and select 'Show Package Contents'
  • Locate the file 'Info.plist' inside the folder 'Contents'
  • Ctrl-click 'Info-plist' and select 'Open with..' and select 'TextEdit' (or your favourite text-editor. Not Word tho.)
  • Near the bottom of the file locate the following segment:

    <key>CFBundleIdentifier</key>
    <string>com.apple.iTunes</string>
  • Change the last 's' in the word 'iTunes' to 'z', like so:

    <key>CFBundleIdentifier</key>
    <string>com.apple.iTunez</string>
  • Save the file

  • IMPORTANT: Drag the file 'iTunes.app' out of the Applications-folder and on to the Desktop
  • Drag the file 'iTunes.app' back into the Applications folder
  • (You should probably disable the iTunesHelper. This can be done by going to System Preferences › Accounts › (Your account) › Login Items and remove the 'iTunesHelper'.)
  • Log out and log in

I hope this works. It works for me!

  • 3
    It works but it seems to damage the iTunes Code Signing Certificate which is ok but everytime you open up iTunes (on a Mac) you'll be asked if the application is allowed to make outgoing connections. – cust0s Sep 20 '09 at 19:17
  • Can't remove the iTunes.app out of Applications... it says "“iTunes” can’t be modified or deleted because it’s required by Mac OS X." – jobwat Dec 12 '13 at 1:12
3

For Snow leopard users: Ok i didnt find an answer for this problem, but i tried to work my way around(for people who wants to watch videos on VLC and pause it with the apple remote/keyboard and itunes keep opening) option 1: open itunes and let it run but click on itunes store and hide itunes or minimize it. continue with watching videos on VLC and music won't play.

option 2: Use Front Row to watch all your videos. To do so install PERIAN for quicktime(which allows you to play all formats in quicktime) and put all your movies in your "movies" folder. Enjoy watching movies through front row.

option 3:(this one worked partially. ) Rename itunes in applications folder to "itunes_off". In order to do this you might need to make your user privileges to" read and write". right click on itunes and click on "get info" then go in privileges and click on little lock icon, enter your password and then change your user setting to "read and write". After this rename itunes to something else. But this solution didnt work correctly for me. it stopped opening itunes for a while but when i restarted my mac it started opening it again. Try if this works for anybody. And keep me posted.

  • Out of all options presented so far, your option 1 seems like an ok work-around; +1 for that – Jonik Sep 1 '09 at 8:10
2

I only used iTunes and Spotify.

I've found the following low-tech solution works:

1. Open iTunes and select one of the folders under "library" that has no content - I never have any "ringtones" for instance; You can also create an empty playlist and select this.

2. Leave iTunes open, but select "Hide iTunes" in the "Itunes" menu.

The results is although iTunes is open it doesn't have any content to play and so when I hit the 'play' button all I hear is music from Spotify.

  • Creating a new empty playlist works as well. Just make sure this playlist is selected. – Paul Lefebvre Oct 19 '11 at 0:13
2

Not sure how many other applications this will work with, but it certainly works with Spotify: if it's already open, pressing option while using the media keys will not open iTunes, and will control Spotify in the background.

  • 1
    Just tried this on my Macbook (OS X 10.6.3) with Spotify & iTunes. iTunes did keep opening despite pressing alt/option along with the media keys. :/ – Jonik Apr 22 '10 at 18:38
  • But if you add shift it works that way! See superuser.com/questions/31925/… – Jonik Apr 22 '10 at 18:41
2

Quick fix that I think is better than these... download functionflip at http://kevingessner.com/software/functionflip/ and check two boxes: "F8: Play/pause" and "Start FunctionFlip at Login." Then go to Ecoute or Spotify or whatever you're using, and set the keyboard shortcut for play/pause to F8 by pressing the play/pause key. Now it'll work just as you want it to, and you will still be able to use it with itunes if you hold down the function (fn) key while you press it.

Works great for me!

1

I have found a solution, though slightly hacky. Basically run iTunes, but select 'Applications' or 'Radio' from the side menu.

That way, when you press the play buttons, there is nothing to play in iTunes so it doesn't do anything, but it works in the application you want to control.

1

There is a patch available at http://www.thebitguru.com/projects/iTunesPatch that will disable opening iTunes when pressing the Play/Pause multimedia key. You have to unzip the file you download from the 'Play Button iTunes Patch 0.7' and run the 'Patch.command' program in the PlayButtonItunesPatch directory.

I have tested it on Snow Leopard (Mac OSX 10.6) and it works flawlessly. Play/Pause continues to work on open programs but will no longer open up iTunes. If you test it please leave feedback in the comments, whether it works or not.

1

Instead of changing the name of iTunes.app, try changing the name of

/Applications/iTunes.app/Contents/MacOS/iTunes

to, for example

iTunes_

This prevents the iTunes.app from working when you double click on it, but at least it saves you from the respawning of iTunes when you press play/pause. If you want to use iTunes.app just rename the file back to "iTunes"

  • Works perfectly, even on Sierra :) – Navin Sep 9 '17 at 3:05
  • On El Capitan this doesn't work: foo:MacOS root# pwd /Applications/iTunes.app/Contents/MacOS foo:MacOS root# mv iTunes iTunes_ mv: rename iTunes to iTunes_: Operation not permitted – Peter Jenkins Dec 28 '17 at 8:01
1

The patches provided here generally don't work on more recent versions of Mac OS X like Mountain Lion. Drawing more attention to @trisweb's answer in a comment:

Latest Mountain Lion patch here: thebitguru.com/projects/iTunesPatch / github: github.com/thebitguru/play-button-itunes-patch

0

This is a work-in-progress solution.. I mainly use XMBC and Hulu so can live without iTunes until there is a real solution:

  1. Delete iTunes from Applications
  2. Delete Front Row from Applications
  3. Empty your trash can

After these steps Hulu and XMBC are usable via the remote again! The only issue is that the Menu Key on the Remote still opens Front Row

=====

Personally I am considering using Win7 on my HTPC Mac Mini. Every app I use on the Mac has a Windows counterpart. It looks like this open source software will let the IR work in Boot Camp: http://www.eventghost.org/

  • As with superuser.com/questions/31925/…, a very limited number of people can take this advice. Many of us want to use iTunes (too), or need it for e.g. iPhone syncing. – Jonik Sep 12 '09 at 22:42
0

In System Preferences, under the Keyboard pane, on the Keyboard tab, enable "Use all F1, F2, etc. keys as standard function keys". Be sure to read the note about getting that functionality back by holding the Fn key.

Assign your Function-keys to various functions either in the Keyboard Shortcuts tab of the Keyboard pane, given application, or other preference pane (Exposé, etc).

Use an application like Quicksilver or Butler to assign actions, applications, and/or AppleScripts to various key shortcuts of your choosing.

0

There was a recent Lifehacker article that pointed how to disable it:

0

this solution is permanent and fool-proof. Go to your login items and take the iTunes Helper out of the login items, then go to Activity monitor (found in the Utilities folder under Applications) and quit out of iTunes Helper. The keys keep working, but iTunes Helper does not reopen and hitting play no longer opens iTunes.

  • 3
    Wrong. iTunes Helper launches iTunes when e.g. an iPhone is connected. I just killed the iTunesHelper process and pressed Play, iTunes still launched. – Daniel Beck Feb 11 '11 at 12:36
0

This has been fixed now with iTunes 10.2 (released the same day the iPad 2 was presented). Now I can use Spotify without having to open an idle instance of Quicktime!

  • I just updated to 10.2.1 and the issue still occurs. – garrow Mar 12 '11 at 11:07
0

I did a sort of low tech thingy that at least prevents iTunes to auto start. I renamed the iTunes.app using:

sudo mv /Applications/iTunes.app /Applications/iTunesX.app

This stops iTunes from autostarting but if you have it started you're still able to use media controls for it.

0

I got around this problem (I only use spotify and iTunes so it probably wasn't as difficult) using an applescript that play/pauses spotify and Quicksilver. It won't work with a remote but If you just want to be able to quickly play/pause spotify without making itunes open and play etc it works like a treat.

This is the applescript if you're interested:

tell application "Spotify" to activate
tell application "System Events"
    tell process "Spotify"
        click menu item 1 of menu 1 of menu bar item 5 of menu bar 1
    end tell
end tell
0

WORKING FIX, simplest and most effective solution (per mritunjai at https://discussions.apple.com/thread/2570254?start=75&tstart=0):

  1. Open Terminal
  2. Enter (these are two separate commands)

    launchctl stop com.apple.rcd
    launchctl unload /System/Library/LaunchAgents/com.apple.rcd.plist
    
0

I realize the OP originally asked about Snow Leopard, but it seems that at least for Spotify, this problem no longer exists on High Sierra -- the remote control buttons work just fine with Spotify and iTunes is no longer started as a side-effect.

0

a solution that worked for me for Mojave was to remove the execution bit from iTunes:

sudo chmod -x /Applications/iTunes.app/Contents/MacOS/iTunes

and optionally add the media player in question under

Preferences -> Security & privacy -> Accessibility

-1

Iospirit claims that their Candelair driver helps to work around this issue as well. more info on their website

-1

Easiest solution: rename itunes.app!

  1. Get read/write permissions on itunes select the app and press ctrl+i click the small lock icon in the bottom left corner enter your password now set "everyone" to read write close the info window
  2. Now you can rename the itunes.app

No more itunes popup open all the time!

protected by BinaryMisfit Mar 3 '11 at 8:09

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.