For a month or so (up to about 2 weeks ago), I was regularly VPN'ing to our work server, and then immediately RDPing to the SAME server using the servers IP address (we aren't behind a NAT).

So assume my server's internet address is

I would VPN to and then RDP to

It worked perfectly. If the VPN wasn't on, RDP didn't work, so it must've been going through the VPN.

Same thing for accessing files, VPN in and then type \\servername\ or \\\ and you could see the files on the server.

Fastforward to today, we haven't changed any configuration on the server, but now its not working. The local computer expert says that it should never have worked that way in the first place, and now we need to add another internal IP and adjust the DNS and all sorts of things.

I'm very frustrated, because I KNOW it used to work.

can anyone shed some light on what could be going on?

  • When you VPN in now, can you do an IPCONFIG/ALL and post the results? I am more interested in the VPN's interface. We you doing RDP using IP address, or host name (it would seem IP based on the question, but just checking)?
    – KCotreau
    Aug 5, 2011 at 5:21
  • Incidentally, it would have been fine for your to VPN into the server, and then RDP to it provided your local VPN connection was given a different IP address. I do it all the time. The key is that YOU get a different IP address. Your expert was not correct.
    – KCotreau
    Aug 5, 2011 at 5:24
  • Ok, something new has happened... today i can VPN in and then access the fileshare at the same server ip address. so whatever was change before has been unchanged. any ideas where i could get a list of the things have been recently changed? also I want to be clear, no matter if you are on the local lan or the world-wide-web, the IP address of all computers at this office is the same (no nat).
    – user92979
    Aug 9, 2011 at 5:39

1 Answer 1


Your server must be blocking RDP from the public IP address. When you VPN'd in, your PC was given a local IP address. Then, when you attach to the server via, the PC is viewed as internal to the LAN, goes through the gateway to access the public IP address... and this is where things get fuzzy. This all depends on how the subnetting, masking, routing tables and gateway are set up. I've seen some strange things with how gateway devices sending traffic to public IPs within the company's netblock.

What I would look at is how the server's firewall is handling requests from various subnets and what applications are allowed connections from which subnet. Windows updates are notorious for changing settings that you wouldn't think would be changed. Also, even if no one fesses up to doing anything to the server, sometimes things that don't seem like related changes can have odd cascading effects.

Or it could be a change to the gateway. when you VPN into the office, you're traffic still has to go out some public facing gateway since the address is public. That is, unless some crazy routing table madness has been put into place.

Finally, choose to use the server's internal address rather than the public one. That would be the preferable behavior anyway, regardless of this strange series of events.

  • Note that the server's internal address IS the public one too. No NAT.
    – user92979
    Aug 7, 2011 at 23:38
  • Can you give some tips on what programs can be used to check those settings?
    – user92979
    Aug 7, 2011 at 23:39
  • If the server's internal address is also the external address, then that probably means that the entire local network isn't RFC 1918 compliant, which isn't a huge problem... some networks are still that way... but it's still odd.
    – Wesley
    Aug 8, 2011 at 5:39
  • The programs to use are simply Windows own firewall control panel as well as the routing and remote access admin tool that is probably what is managing the VPN.
    – Wesley
    Aug 8, 2011 at 5:40
  • The local network has a top-level set of ip addresses (only one ip is not firewalled), its not a typical NAT local network.
    – user92979
    Aug 8, 2011 at 5:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .