4

In April I bought these speakers - http://www.ebuyer.com/94472-logitech-x210-2-1-speakers-970191-0120 - The speakers connect to the sub-woofer and the sub-woofer is connected to the mains, the audio card and a controller dongle.

When I first bought them they crackled a little but I just put up with it, it had happened with the same computer on my old speakers. Having moved house this week I took a little time to try and figure out what the cause is.

I have noticed that the crackling only occurs when my PC is on. It is less frequent when going through POST but picks up when Windows starts loading. It continues whilst the computer is idle but can become louder and more frequent when I am actually using the computer though I cannot figure out a pattern for this.

The crackling occurs whether the sub-woofer is connected to the computer or not. I guess this rules out drivers or volume.

I have tried moving the speakers away from the computer and the crackling doesn't stop or become quieter.

My housemate has suggested that it could be a component inside my PC interfering with the speakers or even perhaps some other device being amplified by the PC.

Is there a way to work out what is causing the crackling or protect the speakers from interference caused by something else?

[I am currently at work at the moment and won't be able to try suggestions til later tonight. I am already planning on trying to connect the speakers directly to the computer instead of the sub-woofer and try to plug it in further away from the PC.]

------ Edit -----

I've moved a few things around and it seems the interference dies out when the 3.5 connector is moved away from the computer and increases substantially when moved close to the audio card. I can't detect a difference when moving around close to the PC so it could be anything in there that's causing it.

3
  • This question would be better moved to; avp.stackexchange.com
    – wonea
    Aug 5 '11 at 11:47
  • So many reasons. I admit, I didn't fully read your post (sorry) as I'm in a rush but, 1. Test speakers in new PC, 2. Change cables/wires, 3 ensure drivers are up to date (doubtful this is the issue), 4, confirm the issue is with audio or not (just turn volumne up with no volume), 5, change location (I think you have done this)
    – Dave
    Aug 3 '15 at 11:04
  • The cabling is probably acting as an antenna, causing interference to occur in the speaker. Related: superuser.com/questions/192061/…
    – bwDraco
    Apr 30 '16 at 19:53
4

You could probably eliminate your PC by plugging the speakers into something else such as an MP3 player, possibly even in another room in your house (if possible).

If using a different device the speakers still crackle, it's the speakers themselves, if they only crackle when connected to/near the PC, it's probably the PC.

3

Maybe the power supply to the speakers is "dirty", i.e. not getting a clean sine wave. Try running an extension cord from a different power outlet, but still using the audio from the PC. If that stops the crackling, then one of your power sockets might not be quite right, or your PC is sending feedback through it. Try using a different power board or wall socket if you have those options.

Also, make sure everything is connected securely, and there is nothing jammed in a plug or socket of the connections. If the speakers have separate wires going into a spring clip that you have to connect rather than RCA plugs, that they are around the right way. While the speakers are crackling, see if you can wiggle any of the cables to affect the crackling, that may also give you a clue.

3
  • It's currently connected to a 6-way that I use for the PC/Monitors, etc which is pretty old and battered, so this could be something to try out. I'll add it to the list to check. Thanks.
    – Septih
    Aug 5 '11 at 11:53
  • 1
    It's also a generally bad idea to run data/audio cables in parallel to power cables. It may be unavoidable right up next to the PC, but try to keep them separate apart from that, if they must cross, make it at a 90 degree angle. This prevents possible induction of noise from the power cable into the data/audio cables.
    – Daniel B.
    Aug 5 '11 at 11:56
  • 1
    Something like that occurred with me before. The problem was just a surge protector. I bought another one - same manufacturer but the most recent "version" - and the noise disappeared. As Electrical Engineer I think it was as camster342 said, a "dirty" power supply, since some manufacturers do not care about a more perfect sine wave.
    – kokbira
    Aug 5 '11 at 12:14
3

This is how I fixed mine after bit of Googling:

  • Turn the stereo off.
  • Quickly turn the volume knob back and forth for about a minute to get rid of most of the grime that is causing the static.
  • Turn it back on.

This should help!

2

Late answer, but it may be helpful to someone.

I just fixed a similar problem at home today (while googling and coming upon this page). Only the left speaker was crackling, connected or disconnected to computer audio output. I disconnected every cable including power, cleaned them, cleaned the sockets and jacks, and put them back together. No improvement. I then let the speakers play hard rock on higher volume and went away for about 30 mins. I return, stop the player and the crackling is gone !! (No, I have not gone momentarily deaf :-) I can hear my CPU fan). Try it out, it may work.

I do not know why but maybe some residual charge inside speaker was flushed when I turned up the volume. Like a loudspeaker or speakerphone whining. I am using Altec Lansing MX 5021, BTW. I never faced this earlier, it is probably showing its age now.

There was still a slight humming. I muted the microphone from my sound driver application, and that humming is also gone.

I've moved a few things around and it seems the interference dies out when the 3.5 connector is moved away from the computer and increases substantially when moved close to the audio card.

============

I faced the same problem once with my Sony Walkman. It turned out to be a bad AC adapter. It worked fine when I used it on battery.

Update: If speakers are old (e.g. around ten years), their electronics tends to have a buzz or crackling. I have experienced it with many speakers.

I find that there is a buzz and/or ticking static discharge sounds when I play audio over bluetooth. I have seen such reviews often on Amazon for bluetooth speakers, however costly or cheap the speakers are. It seems that most bluetooth audio hardware and/or software has not aged and hardened yet.

1

I was experiencing the same problem, then i checked the speakers by playing songs from my phone and found that speakers were working fine.

What i did to solve the problem (on windows 7)

  • right click the speaker icon in the tasks-bar
  • go to "playback devices"
  • right click on "speakers", go to "properties"
  • go to "levels" tab
  • slide "Rear Pink In"(my mic was plugged in) to minimumn level
  • click "OK"

After doing this, my speakers stopped crackling.

As Satish Motwani said, late answer but it may be helpful to someone.

1

I'm a little ashamed to revive such an old question but I had this problem coming up on my Creative A500 5.1 speakers and as it is the first the result when I google this problem I might post what worked in my case.

I was watching a movie and fell asleep when I woke up there was some random static and crackling most noticeable on the right channel. Did most of the things pointed on this post, like:

  • Moving the volume knob on full range. Also applied some electric cleansing spray too.
  • Cleaning the 3.5mm connectors and also cleaning the RCA speakers connectors.
  • Connected to another AC outlet
  • Isolated the AC adpater from data/sound cables to rule out some interference
  • Tryed multiple sound sources such as iPods, computers, consoles, etc.
  • Played music at full volume

Neither of this cleared out the problem. Also this crackling was noise still happening while it was disconnected from any appliance. So the problem must be in the speakers, specifically on the driver board located on the sub woofer in my case.

While the speakers were turned on I disconnected the AC adapter, hoping it would discharge any capacitor on the board. Then unscrew the board to take a look at it. As I examined it I saw some corrosion bridging some components. I got a brass brush a gave it a good scruff so I can see some of the pcb board between the solder points, thus cleaning the corrosion. Then wiped the board with isopropyl alcohol 99% to clean any debris from the brushing. Then when I tested it out the problem was gone.

I think the problem happened because of the age of this speaker and that in the winter it tends to be fairly humid where I live. So over time the corrosion grew to the point it got to make a bridge that made this static/crackling sound.

Hope this will help people on the future.

-3

I am currently using speakers via FM frequency via a Laptop and mixer desk and thought that I may be picking up frequent noises such as crackles and a random increase and decrease in the volume level of crackle and hum due to my equipment of which is all new! Does this sound familiar to anyone?

Further investigation ruled out any of my components and brought me back to the power source and that being in a large store and having multiple power drops available however, it turns out every time I shook the power cables also found the noise would increase and decrease. I investigated further and found the following when using expensive equipment including FM or WiFi appliances your power cables should not be the cheap ones for $6 - $10 as, like me, you are asking for trouble because as soon as I purchased and applied heavy duty cables the crackles have gone however, but I still had very low hum.

After talking to commercial music store service department they advise cutting off the earth pin from the extension cable that joined up to the power leads of the components speaker and receiver to stop the hum and amazingly that worked I now have clean sound.

I strongly advise the following check first always check your power source and power cables adaptors and boards first; leave everything turned off except your speaker/s then if they are active turn your volume up to a 1/3 of the way shake your power cables and just see if the crackles come and go with the movement and change your power cables for heavy duty lines. Hope this helps anyone faced with the same nightmare.

2
  • 1
    I don't recommend cutting the ground pin. The issue you're describing here is a ground loop; you should try getting a ground loop isolator device instead.
    – bwDraco
    Apr 30 '16 at 20:04
  • 2
    The ground pin is a safety feature of the plug, removing it is very dangerous.
    – Burgi
    May 14 '16 at 15:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.